ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

[ROS2] UserWarning: Usage of dash-separated 'install-scripts' will not be supported in future versions. Please use the underscore name 'install_scripts' instead

asked 2021-09-12 11:08:19 -0600

smlajoos gravatar image

lars@larsmachine:~/teach_ws$ colcon build

Starting >>> topic_package /usr/local/lib/python3.8/dist-packages/setuptools/dist.py:714: UserWarning: Usage of dash-separated 'script-dir' will not be supported in future versions. Please use the underscore name 'script_dir' instead warnings.warn(

/usr/local/lib/python3.8/dist-packages/setuptools/dist.py:714: UserWarning: Usage of dash-separated 'install-scripts' will not be supported in future versions. Please use the underscore name 'install_scripts' instead warnings.warn(

--- stderr: topic_package
/usr/local/lib/python3.8/dist-packages/setuptools/dist.py:714: UserWarning: Usage of dash-separated 'script-dir' will not be supported in future versions. Please use the underscore name 'script_dir' instead warnings.warn(

/usr/local/lib/python3.8/dist-packages/setuptools/dist.py:714: UserWarning: Usage of dash-separated 'install-scripts' will not be supported in future versions. Please use the underscore name 'install_scripts' instead warnings.warn(


Finished <<< topic_package [0.53s]

Summary: 1 package finished [0.64s] 1 package had stderr output: topic_package

Problem Discription

I get this UserWarning everytime I build my workspace. Seems to be a problem with python3... This error is occuring for every building process of each package, since I've installed some debian packages for a YOLO package...

The building process still works, but in my usual workspace with >10 packages these error warnings are quite annoying. By changing "install-scripts" and "build-type" in the setup.cfg file to "install_scripts" and "build_type" the warning doesn't occur anymore. I'm using ubuntu 20.04, ros2-foxy and python 3.810.

I already tried unsuccessfully to uncomment this warning in the dist.py.

edit retag flag offensive close merge delete

Comments

Hi there, I had the same issue on ROS2 Humble and I applied the suggested solution to replace the dash with an underscore but I still get warnings:

From this:

--- stderr: my_turtlesim /usr/lib/python3/dist-packages/setuptools/command/easy_install.py:158: EasyInstallDeprecationWarning: easy_install command is deprecated. Use build and pip and other standards-based tools. warnings.warn( /usr/lib/python3/dist-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools. ...

Is there any fix for this?

dave gravatar image dave  ( 2022-10-16 03:37:59 -0600 )edit
1

According to this link: https://answers.ros.org/question/3964...

The reason is a too new version of the setuptools. It can be solved by installing an older version on Ubuntu 22.04 (using version 58.2.0 instead of the newer 59.6.0) with pip install setuptools==58.2.0 and it shows no warnings anymore.

dave gravatar image dave  ( 2022-10-16 03:56:10 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2023-03-16 09:48:10 -0600

Of course changing to an older version of setup tools will work around the problem temporarily, but the correct way to fix this is to just change all of the instances of "script-dir"-->"script_dir" and "install-scripts"-->"install_scripts" in your setuptools configuration files (i.e. "setup.cfg" files).

edit flag offensive delete link more
0

answered 2021-10-11 10:36:55 -0600

kolasha gravatar image

Hey Lars, thank you for the contribution.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2021-09-12 11:08:19 -0600

Seen: 5,243 times

Last updated: Sep 12 '21