Terrible frequencies using NXT_ROS over Bluetooth [closed]

asked 2012-07-11 04:05:12 -0500

andreasw gravatar image

updated 2014-01-28 17:12:58 -0500

ngrennan gravatar image

Hi,

I'm trying to use NXT_ROS over Bluetooth on Ubuntu 11.04 and ROS electric but the frequencies I get are terrible:

[WARN] [WallTime: 1342015201.551490] ultrasonic_sensor not reaching desired frequency: 
actual 3.919776, desired 8.000000
[WARN] [WallTime: 1342015201.813812] caught an exception nxt.error.DirProtError
[WARN] [WallTime: 1342015201.814099] motor_left not reaching desired frequency: 
actual 0.180869, desired 8.000000
[WARN] [WallTime: 1342015201.814297] motor_right not reaching desired frequency: 
actual 0.180868, desired 8.000000

Is there anything I could do about it?

Best regards, Andreas

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-03-26 18:21:08.598445

Comments

Your motors are publishing at a rate of about 5.528863432 Hz, and your ultrasonic sensor is publishing at a rate of about 0.255116619 Hz. You could look into your yaml files and change your publishing rate. I don't know about making it faster, but ROS will know to expect it that slow.

allenh1 gravatar imageallenh1 ( 2012-07-11 06:59:00 -0500 )edit

Thanks for the reply, allenh1. The problem with these frequencies is, that updates seem to get lost, e.g. I had been holding a touch sensor pressed for ~2 minutes at a frequency around 0.3 Hz but it didn't seem to publish anything.

andreasw gravatar imageandreasw ( 2012-07-30 21:48:04 -0500 )edit