ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

libstatistics_collector: Unknown CMake command "rosidl_get_typesupport_target" (galactic)

asked 2021-08-07 10:24:25 -0600

baila gravatar image

updated 2021-08-07 10:50:47 -0600

gvdhoorn gravatar image

Hello everyone, I am trying to build ROS2 from source following the galactic link. While building, I am getting the below error,

Starting >>> shape_msgs
--- stderr: libstatistics_collector
CMake Error at CMakeLists.txt:100 (rosidl_get_typesupport_target):
  Unknown CMake command "rosidl_get_typesupport_target".


make: *** [Makefile:1130: cmake_check_build_system] Error 1
---
Failed   <<< libstatistics_collector [5.11s, exited with code 2]
Aborted  <<< shape_msgs [1.76s]
Aborted  <<< rclpy [2.80s]
Aborted  <<< map_msgs [4.19s]

Summary: 176 packages finished [1min 34s]
  1 package failed: libstatistics_collector
  3 packages aborted: map_msgs rclpy shape_msgs
  1 package had stderr output: libstatistics_collector
  150 packages not processed

I tried to comment it in "src/ros-tooling/libstatistics_collector/CMakeLists.txt" file, but it leads to some other failure. Need some help here.

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2021-08-07 10:47:39 -0600

gvdhoorn gravatar image

updated 2021-08-07 10:49:29 -0600

This is probably the same cause as is fixed by ros2/ros2#1166.

Try changing the active branch for ros-tooling/libstatistics_collector to galactic.

It's set to master here, but that isn't correct any more since ros-tooling/libstatistics_collector#116.

I tried to comment it in "src/ros-tooling/libstatistics_collector/CMakeLists.txt" file, but it leads to some other failure.

yes, don't do that.

That function call is there for a reason.

edit flag offensive delete link more

Comments

Thanks a lot for the solution. It fixed the build error. :)

baila gravatar image baila  ( 2021-08-07 12:12:20 -0600 )edit

Thank you! I had similar build error; used ROS2 Foxy, but ROS2 tutorial's branch was rolling, when corrected the branch as suggested (foxy-devel in my case) this "rosidl_get_typesupport_target" build error disappeared.

mnokka gravatar image mnokka  ( 2021-10-14 04:14:55 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2021-08-07 10:24:25 -0600

Seen: 3,456 times

Last updated: Aug 07 '21