ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Trying to setup ROS microphone capture with audio_common package. Catkin wont make.

asked 2021-07-19 12:01:39 -0500

matthewfwork gravatar image

updated 2021-07-20 09:40:59 -0500

This is the repo i am using I get this error after setting up the repo in the catkin src folder.

-- Checking for module 'gstreamer-1.0' -- No package 'gstreamer-1.0' found CMake Error at /usr/share/cmake-3.16/Modules/FindPkgConfig.cmake:463 (message): A required package was not found Call Stack (most recent call first): /usr/share/cmake-3.16/Modules/FindPkgConfig.cmake:643 (_pkg_check_modules_internal) audio_common/audio_capture/CMakeLists.txt:8 (pkg_check_modules)

-- Configuring incomplete, errors occurred! See also "/home/ubuntu/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/ubuntu/catkin_ws/build/CMakeFiles/CMakeError.log". Invoking "cmake" failed

I tried installing gstreamer-1.0 just to be told this it is already installed. When I try to purge gstreamer I get told it does not exist. I am stuck with this one any help would be greatly appreciated.

Error after installing libgstreamer1.0-dev and catkin making again.

Building CXX object audio_common/audio_play/CMakeFiles/audio_play.dir/src/audio_play.cpp.o /home/ubuntu/catkin_ws/src/audio_common/audio_play/src/audio_play.cpp:2:10: fatal error: gst/app/gstappsrc.h: No such file or directory 2 | #include <gst app="" gstappsrc.h=""> | ^~~~~~~~~~~~~~~~~~~~~ compilation terminated. make[2]: * [audio_common/audio_play/CMakeFiles/audio_play.dir/build.make:63: audio_common/audio_play/CMakeFiles/audio_play.dir/src/audio_play.cpp.o] Error 1 make[1]: [CMakeFiles/Makefile2:1983: audio_common/audio_play/CMakeFiles/audio_play.dir/all] Error 2 make[1]: Waiting for unfinished jobs.... /home/ubuntu/catkin_ws/src/audio_common/audio_capture/src/audio_capture.cpp:3:10: fatal error: gst/app/gstappsink.h: No such file or directory 3 | #include <gst app="" gstappsink.h=""> | ^~~~~~~~~~~~~~~~~~~~~~ compilation terminated. make[2]: [audio_common/audio_capture/CMakeFiles/audio_capture.dir/build.make:63: audio_common/audio_capture/CMakeFiles/audio_capture.dir/src/audio_capture.cpp.o] Error 1 make[1]: [CMakeFiles/Makefile2:1937: audio_common/audio_capture/CMakeFiles/audio_capture.dir/all] Error 2 [ 97%] Built target sound_play_generate_messages_eus make: * [Makefile:141: all] Error 2 Invoking "make -j4 -l4" failed

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2021-07-19 16:48:47 -0500

Mike Scheutzow gravatar image

You need to install the gstreamer development package using apt-get. On Ubuntu, the apt package is usually named libgstreamer1.0-dev

Yes, it'd be easier to figure out if the naming was consistent.

edit flag offensive delete link more


so the install worked and catkin make managed to make it to 97% then this error occurred. See above for revised post

matthewfwork gravatar image matthewfwork  ( 2021-07-20 09:40:24 -0500 )edit

That's a different apt package. You should be able to google for it.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-07-20 09:56:48 -0500 )edit

you mean gstappsink? im sorry if i am asking the obvious i am new to all this

matthewfwork gravatar image matthewfwork  ( 2021-07-20 12:08:01 -0500 )edit

You can often get good results by putting the error message into google. Alternatively, have you tried googling: ubuntu package gstappsink.h ?

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-07-20 20:40:45 -0500 )edit

Question Tools

1 follower


Asked: 2021-07-19 12:01:39 -0500

Seen: 219 times

Last updated: Jul 20 '21