Galactic rosbag2 deb package broken?

asked 2021-06-11 08:17:18 -0600

pimenoff-aerones gravatar image

I'm getting this after recent system update:

        Traceback (most recent call last):
        File "rosbag.py", line 3, in <module>
          import rosbag2_py
        File "/opt/ros/galactic/lib/python3.8/site-packages/rosbag2_py/__init__.py", line 21, in <module>
          from rosbag2_py._reader import (
        ImportError: /opt/ros/galactic/lib/python3.8/site-packages/rosbag2_py/_reader.cpython-38-x86_64-linux-gnu.so: undefined  symbol: _ZNK15rosbag2_storage14StorageFactory30get_declared_read_only_pluginsB5cxx11Ev

I have also tried to reinstall all rosbag2 related packages:

sudo apt install --reinstall ros-galactic-rosbag2 ros-galactic-rosbag2-compression ros-galactic-rosbag2-compression-dbgsym ros-galactic-rosbag2-compression-zstd ros-galactic-rosbag2-compression-zstd-dbgsym ros-galactic-rosbag2-cpp ros-galactic-rosbag2-cpp-dbgsym ros-galactic-rosbag2-interfaces ros-galactic-rosbag2-interfaces-dbgsym ros-galactic-rosbag2-performance-benchmarking ros-galactic-rosbag2-py ros-galactic-rosbag2-storage ros-galactic-rosbag2-storage-dbgsym ros-galactic-rosbag2-storage-default-plugins ros-galactic-rosbag2-storage-default-plugins-dbgsym ros-galactic-rosbag2-test-common ros-galactic-rosbag2-tests ros-galactic-rosbag2-transport ros-galactic-rosbag2-transport-dbgsym

except ros-galactic-rosbag2-bag-v2-plugins

which

Depends: ros-galactic-ros1-bridge but it is not going to be installed

which in turn requires noetic

The following packages have unmet dependencies:

ros-galactic-ros1-bridge : Depends: ros-noetic-actionlib-msgs but it is not installable

                       Depends: ros-noetic-catkin but it is not installable
                       Depends: ros-noetic-common-msgs but it is not installable
                       Depends: ros-noetic-gazebo-msgs but it is not installable
                       Depends: ros-noetic-geometry-msgs but it is not installable
                       Depends: ros-noetic-nav-msgs but it is not installable
                       Depends: ros-noetic-rosbash but it is not installable
                       Depends: ros-noetic-roscpp but it is not installable
                       Depends: ros-noetic-roscpp-tutorials but it is not installable
                       Depends: ros-noetic-roslaunch but it is not installable
                       Depends: ros-noetic-rosmsg but it is not installable
                       Depends: ros-noetic-rospy-tutorials but it is not installable
                       Depends: ros-noetic-sensor-msgs but it is not installable
                       Depends: ros-noetic-std-msgs but it is not installable
                       Depends: ros-noetic-std-srvs but it is not installable
                       Depends: ros-noetic-stereo-msgs but it is not installable
                       Depends: ros-noetic-tf but it is not installable
                       Depends: ros-noetic-tf2-msgs but it is not installable
                       Depends: ros-noetic-trajectory-msgs but it is not installable
                       Depends: ros-noetic-visualization-msgs but it is not installable

I'm using Ubuntu 20.04 and ROS2 Galactic

edit retag flag offensive close merge delete