ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Need advice on why I'm having -Bash issues

asked 2021-05-19 15:54:09 -0600

TexAcoon gravatar image

updated 2021-05-20 01:45:33 -0600

gvdhoorn gravatar image

Doing my best to load ROS and other programs but having some really bad luck. Using Ubuntu 18.04 through Windows 10 I get the following messages that I cant clean up … I have exhausted my research and gone through the tutorials trying to figure out where I messed up on my install. Sure could use some expert help getting my programming ironed out.

-bash: /home/waypoint/turtlebot3_ws/install/setup.bash: No such file or directory
-bash: /opt/ros/melodic/setup.bash: No such file or directory
-bash: /opt/ros/melodic/setup.bash: No such file or directory
-bash: source/opt/ros/jade/setup.bash: No such file or directory
-bash: /opt/ros/kinetic/setup.bash: No such file or directory
-bash: /opt/ros/kinetic/setup.bash: No such file or directory
-bash: /opt/ros/noetic/setup.bash: No such file or directory
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2021-05-20 01:52:00 -0600

gvdhoorn gravatar image

updated 2021-05-20 01:52:22 -0600

You most likely have multiple source /.../setup.bash lines in the .bashrc file in your $HOME directory.

Additionally: we see mentions of melodic, jade, noetic and kinetic.

Those ROS versions cannot be installed on the same version of Ubuntu (or Windows for that matter), so something must have gone wrong. Have you tried to follow multiple installation tutorials, for different versions of ROS?

To rectify this situation:

  • open the .bashrc file, for instance using nano: nano -w $HOME/.bashrc (I'm assuming you don't have a GUI for your Linux install, as you mention you're using Ubuntu in WSL on Windows 10, if you do have a GUI, you could use gedit $HOME/.bashrc)
  • now scroll all the way down to the end of the file (using the arrow keys)

you should see something like this:

source /home/waypoint/turtlebot3_ws/install/setup.bash
source /opt/ros/melodic/setup.bash
source /opt/ros/melodic/setup.bash
source source/opt/ros/jade/setup.bash
source /opt/ros/kinetic/setup.bash
source /opt/ros/kinetic/setup.bash
source /opt/ros/noetic/setup.bash

For now, just remove all of those lines (using the backspace or delete keys). Then save the file using ctrl+o, enter, ctrl+x.

If you did it correctly, the errors should be gone.

At this point you probably want to verify you've actually installed ROS, as the errors you show seem to indicate your install wasn't successful, and some important files are missing.

What's the output of ls -al /opt/ros/{melodic,noetic}?

edit flag offensive delete link more


Thank you gvdhoorn .. I think you are right about different ROS installations on the same version of Ubuntu.. And have also tried to install in Windows .. yet both seem to be a real mess.

Just got back today and will try to use your reference to rectify the issues I am having .. Once done I will report back and give you my update.

So I guess I'm a bit confused about installing ROS for Ubuntu OR Windows - What is the best avenue for either? .. Last report I saw was kinetic was going out and everyone needed to go to Melodic ..

Being a new user and reading various forums and have a book on ROS systematic learning .. I'm am really behind the eight ball right now..

Any advice would be appreciated..

Thanks! Doug

TexAcoon gravatar image TexAcoon  ( 2021-05-25 20:09:34 -0600 )edit

Using nano -w $HOME/.bashrc = I have removed the following data.

source /home/waypoint/turtlebot3_ws/install/setup.bash
source /opt/ros/melodic/setup.bash
source /opt/ros/melodic/setup.bash
source source/opt/ros/jade/setup.bash
source /opt/ros/kinetic/setup.bash
source /opt/ros/kinetic/setup.bash
source /opt/ros/noetic/setup.bash

This is what I have left with the GNU nano 2.9.3

source ~/turtlebot3_ws/install/setup.bash
source ~/catkin_ws/devel/setup.bash
source ~/catkin_ws/devel/setup.bash
alias eb='nano ~/.bashrc'
alias sb='source ~/.bashrc'
alias gs='git status'
alias gp='git pull'
alias cw='cd ~/catkin_ws'
alias cs='cd ~/catkin_ws/src'
alias cm='cd ~/catkin_ws && catkin_make'
source ~/catkin_ws/devel/setup.bash
export ROS_MASTER_URI=http://localhost:11311
export ROS_HOSTNAME=localhost
export TURTLEBOT3_MODEL=burger

Do you recommend removing something else out of the inventory or install something that actually works for the ROS programming?

Thanks Doug

TexAcoon gravatar image TexAcoon  ( 2021-05-25 20:17:50 -0600 )edit

I also found that my ROS info is in my H: drive which is another drive that is larger than my main drive C: due to the amount of data I have stored on C: - been installing new programs on the alternate drive. SO with this in mind it had some how messed up the install is what I see. May have to do another install to my main on C: to make it work .. Funny how you find something with others helping... Doug

TexAcoon gravatar image TexAcoon  ( 2021-05-25 20:31:26 -0600 )edit

Question Tools

1 follower


Asked: 2021-05-19 15:54:09 -0600

Seen: 194 times

Last updated: May 25 '21