Ask Your Question
1

Noetic Buster 64 bit libgl-dev (Raspberry pi 4)

asked 2021-03-11 18:34:04 -0500

HelloThere gravatar image

updated 2021-03-12 03:33:18 -0500

gvdhoorn gravatar image

Hello, I set up my raspberry Pi 4 with Buster64 bit OS. I tried to install the Noetic distribution via the given steps on http://wiki.ros.org/noetic/Installati... but failed the installation due libgl-dev not present. The OP is below:

pi@raspberrypi:/var/cache/apt/archives $ sudo apt-get install ros-noetic-desktop 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ros-noetic-desktop is already the newest version (1.5.0-1buster.20210206.145732).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libgl1-mesa-dev : Depends: libgl-dev
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

How would i find that particular file, i tried to look it up on debian packages and raspberry pi forums too. Please do guide.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-03-12 06:35:27 -0500

alexspi13 gravatar image

Try to install the specific package that is missed. Search libgl-dev package install for your OS.

edit flag offensive delete link more

Comments

I did but ended up getting an error.

The following NEW packages will be installed: libgl-dev 0 upgraded, 1 newly installed, 0 to remove and 184 not upgraded. 639 not fully installed or removed. Need to get 0 B/100 kB of archives. After this operation, 1,389 kB of additional disk space will be used. (Reading database ... 145167 files and directories currently installed.) Preparing to unpack .../libgl-dev_1.3.0-7~bpo10+1_arm64.deb ... Unpacking libgl-dev:arm64 (1.3.0-7~bpo10+1) ... dpkg: error processing archive /var/cache/apt/archives/libgl-dev_1.3.0-7~bpo10+1_arm64.deb (--unpack): trying to overwrite '/usr/include/KHR/khrplatform.h', which is also in package libraspberrypi-dev 2+git20200520~143707+2fe4ca3-1 Errors were encountered while processing: /var/cache/apt/archives/libgl-dev_1.3.0-7~bpo10+1_arm64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

HelloThere gravatar image HelloThere  ( 2021-03-12 09:45:44 -0500 )edit

I solve my problem when I installed ubuntu server in RPi. I was trying to install ros 4 days in buster. So go to ubuntu server and you will finish it in one day. Trust me.

alexspi13 gravatar image alexspi13  ( 2021-03-12 13:08:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-03-11 18:34:04 -0500

Seen: 121 times

Last updated: Mar 12