Ask Your Question
0

Running LGSVL with Autoware.Auto: ROS2 bridge disconnected

asked 2021-02-11 17:50:16 -0600

RevatiNaik gravatar image

updated 2021-02-11 17:58:27 -0600

I start the ADE and the LGSVL inside ADE using the command ade --rc .aderc-lgsvl start --update --enter. Next I need to run the simulator alongside Autoware.Auto for which the command is ade start -- --net=host --privileged. This is also the command to allow connecting to ros bridge.

How do I run two ade start commands? They both conflict.

I start the LGSVL from the folder (not through ade using /opt/lgsvl/simulator) and then start ADE with the second start command. This shows Bridge Status: Connecting for a long time but could not connect. I stopped the simulation and then started it again, it then shows Bridge Status: Disconnected.

Any suggestions?

I followed this Link

Run Simulator alongside Autoware.Auto

Start the Autoware.Auto containers: cd ~/adehome/AutowareAuto ade start -- --net=host --privileged # to allow connect to rosbridge

Enter the container and start rviz2: ade enter cd ~/AutowareAuto colcon build # If you want to use autoware_auto_msgs, ros2-web-bridge needs to compile them export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/local/nvidia/lib64/ source ~/AutowareAuto/install/local_setup.bash rviz2 -d /home/"${USER}"/AutowareAuto/install/autoware_auto_examples/share/autoware_auto_examples/rviz2/autoware.rviz

Start (resume) the LGSVL Simulator:

Note this is LGSVL Simulator, downloaded from LGSVLSimulator.com, version 2020.05 Launch the executable and click on the button to open the web UI Click "Simulations" to view the available/configured simulations Click in BorregasAve (Autoware.Auto/ROS2) simulation to select it (indicated by check mark) Click "Play" icon to begin simulation

Launch ROS2 web bridge (in a new shell) NOTE: Node.js will need to be re-installed (above) in the container after ADE is started ade enter # ros2 web bridge should be run in ade environment cd ros2-web-bridge source ~/AutowareAuto/install/local_setup.bash node bin/rosbridge.js

In RViz window:

Under "Global Options", set "Fixed Frame" to lidar_front

Expand "Tranformed Points" and set "Topic" to /lidar_front/points_raw

You should now be able to see the lidar point cloud in RViz

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2021-03-28 22:25:50 -0600

zhensheng gravatar image

you need to use the latest lgsvl ros2 bridge instead of the old web-socket bridge, see link https://www.svlsimulator.com//docs/sy...

edit flag offensive delete link more
0

answered 2021-03-20 10:30:23 -0600

marcusvini178 gravatar image

Hi I am working around the same issue have you found the solution?

edit flag offensive delete link more

Comments

Hi, I followed these steps to successfully run the simulator with ADE.

Follow this link: Running LGSVL with Autoware.Auto

  1. To start the LGSVL simulator, in the same terminal window:

    ade$ /opt/lgsvl/simulator

Go to http://127.0.0.1:8080 where simulations can be configured.

  1. Follow the steps given in "Creating a simulation" on the page of the link shared above. These changes are made on http://127.0.0.1:8080

  2. Bridging with Autoware.Auto: To run the lgsvl_interface manually, enter the following in a new terminal window:

    $ ade enter

    ade$ source /opt/AutowareAuto/setup.bash

    ade$ ros2 run lgsvl_interface lgsvl_interface_exe --ros-args --params-file /opt/AutowareAuto/share/lgsvl_interface/param/lgsvl.param.yaml

  3. In a new terminal window launch the trajectory test node:

    ros2 launch test_trajectory_following simple_trajectory_following.launch.py sim_type:=lgsvl

RevatiNaik gravatar image RevatiNaik  ( 2021-03-20 23:32:36 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-02-11 17:50:16 -0600

Seen: 345 times

Last updated: Mar 20