Ask Your Question
0

UWSim install error - not installing osgocean

asked 2012-06-21 02:05:31 -0500

umesh gravatar image

I'm trying to install UWSim

http://www.irs.uji.es/uwsim/wiki/index.php?title=Installing_UWSim

It installs the first 16 packages, but encounters an error when installing osgocean. The message is

    [rosmake-2] Starting >>> urdf [ make ]                                                                                                                                  
[rosmake-2] Finished <<< urdf ROS_NOBUILD in package urdf                                                                                                               
[ rosmake ] All 12 lines
{-------------------------------------------------------------------------------
  make wipe
  make[1]: Entering directory `/opt/ros/fuerte/stacks/underwater_simulation/osgOcean'
  rm -rf lib
  rm -rf include
  rm -rf share
  rm -rf build
  rm -rf installed
  touch wiped
  touch: cannot touch `wiped': Permission denied
  make[1]: *** [wipe] Error 1
  make[1]: Leaving directory `/opt/ros/fuerte/stacks/underwater_simulation/osgOcean'
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package osgOcean written to:
[ rosmake ]    /home/umesh/.ros/rosmake/rosmake_output-20120621-163553/osgOcean/build_output.log          
[rosmake-0] Finished <<< osgOcean [FAIL] [ 0.04 seconds ]                                                                                                               
[ rosmake ] Halting due to failure in package osgOcean. 
[ rosmake ] Waiting for other threads to complete.                                                             
[ rosmake ] Results:                                                                                                                                                    
[ rosmake ] Built 17 packages with 1 failures.                                                                                                                          
[ rosmake ] Summary output to directory

All dependancies are installed.

edit retag flag offensive close merge delete

Comments

Solved! it was an md5 sum mismatch. downloaded manually and replaced the tarball.

umesh gravatar image umesh  ( 2012-06-22 02:16:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-22 02:17:19 -0500

umesh gravatar image

Solved! it was an md5 sum mismatch. downloaded manually and replaced the tarball.

edit flag offensive delete link more

Comments

Good. Anyway, the error seems more related to write permisions under the opt/ folder. You should probably create a ros workspace somewhere under your home folder (http://www.ros.org/wiki/ROS/Tutorials/InstallingandConfiguringROSEnvironment#Create_a_ROS_Workspace)

Mario Prats gravatar image Mario Prats  ( 2012-06-22 08:16:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-06-21 02:05:31 -0500

Seen: 162 times

Last updated: Jun 22 '12