Ask Your Question
0

How to un-break a ROS installation that doesn't know where to find any stacks/packages?

asked 2012-06-19 17:50:54 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I installed ROS Fuerte by following the online tutorial for Gentoo and running:

rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=fuerte&variant=desktop-full&overlay=no"

This installed ROS into /opt/ros/fuerte and my stacks into ~/ros. Later, I wanted to install another stack from source so I asked this question. Following everything after "Now add the repository you want to check out" didn't work so I decided to re-init my workspace by running

rosws init ~/ros /opt/ros/fuerte

And then add the respository.

This worked - now ROS knows about the brown_remotelab stack I was adding - except now it's forgotten about all my other stacks. I've tried re-adding them manually by following the same instructions I followed for brown_remotelab. This doesn't work because the other stacks don't seem to be a kept in a subversion repository. For example, trying to reinstall the image_transport_plugins stack by running:

roscd
rosws set image_transport_plugins https://code.ros.org/trac/ros-pkg/browser/trunk/stacks/image_transport_plugins --svn
rosws update image_transport_plugins

Generates the error:

Failed to detect svn presence at /root/ros/image_transport_plugins. (d)elete and replace, (a)bort, (b)ackup and replace, (s)kip:

And choosing (d)elete and replace doesn't work because svn co https://code.ros.org/trac/ros-pkg/browser/trunk/stacks/image_transport_plugins fails.

So how do I re-add the rest of my stacks manually or otherwise tell ROS that they are there and that it should be able to see them?

edit retag flag offensive close merge delete

Comments

What does your ROS_PACKAGE_PATH currently contain?

SL Remy gravatar image SL Remy  ( 2012-06-19 18:28:08 -0500 )edit

/root/ros/brown_remotelab:/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros. Which is obviously wrong but it gets set by setup.sh

Shum gravatar image Shum  ( 2012-06-19 20:57:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-06-19 23:53:23 -0500

Lorenz gravatar image

updated 2012-06-19 23:53:48 -0500

As you already noticed, your repository URL is wrong. Use:

rosws set image_transport_plugins https://code.ros.org/svn/ros-pkg/stacks/image_transport_plugins/trunk --svn
rosws update image_transport_plugins

The URLs for stacks that are tracked by the ROS wiki indexer can be easily found by using roslocate. E.g.:

roslocate info image_transport_plugins

This will output a rosinstall file. For quickly adding it to your ros workspace you can do:

roslocate info image_transport_plugins >> ~/ros/.rosinstall
rosws update image_transport_plugins

Finally, either re-source ~/ros/setup.bash or open a new terminal.

edit flag offensive delete link more

Comments

We need a wiki page explaining how to set up source workspaces after installing ROS from binary Ubuntu packages. That seems to confuse many people.

joq gravatar image joq  ( 2012-06-20 04:01:08 -0500 )edit

Actually, I think this should become part of the install tutorial. I never really understood why it didn't even mention rosinstall/rosws.

Lorenz gravatar image Lorenz  ( 2012-06-20 04:02:56 -0500 )edit

Agreed. What I have in mind is a relatively generic "how to create source overlays" page with links at the end of various install pages for "if you need to build source packages that work with what you just installed". Most people need that, but not everyone.

joq gravatar image joq  ( 2012-06-20 04:23:56 -0500 )edit

Ticketed it here: https://code.ros.org/trac/ros/ticket/3993@joq@Lorenz It's assigned to me but feel free to take it on.

tfoote gravatar image tfoote  ( 2012-06-21 21:07:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-19 17:50:54 -0500

Seen: 247 times

Last updated: Jun 19 '12