ROS Serial Arduino cstring error [closed]

asked 2020-12-24 04:01:04 -0500

Joesan gravatar image

I'm using ROS Noetic on my Ubuntu 20.04 and I wanted to try out a simple Arduino ROS interface example, but unfortunately I ran into errors. I did install the needed libraries as per instructions that I found in this page here:

I then opened the Blink sketch and when I clicked Verify, it failed with the following error:

>     In file included from /home/joesan/Arduino/libraries/Rosserial_Arduino_Library/src/std_msgs/Time.h:7:0,
>                      from /home/joesan/Arduino/libraries/Rosserial_Arduino_Library/src/ros/node_handle.h:40,
>                      from /home/joesan/Arduino/libraries/Rosserial_Arduino_Library/src/ros.h:38,
>                      from /home/joesan/Arduino/libraries/Rosserial_Arduino_Library/examples/Blink/Blink.pde:6:
>     /home/joesan/Arduino/libraries/Rosserial_Arduino_Library/src/ros/msg.h:40:10:
> fatal error: cstring: No such file or
> directory
>      #include <cstring>
>               ^~~~~~~~~
>     compilation terminated.
>     exit status 1
>     Error compiling for board Arduino Uno.

Any ideas how to get this fixed? I even tried running this:

rosrun rosserial_arduino .

But even that gave me the same error! It is quite annoying to face this issue for running a simple program. Help please!

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by sloretz
close date 2020-12-28 10:14:22.055845


Duplicate: See answers on this quetion #q361930

sloretz gravatar image sloretz  ( 2020-12-28 10:13:55 -0500 )edit