I can't source the setup.bash file automatically for ROS noetic

asked 2020-12-15 14:23:13 -0500

SIA gravatar image

Hi. I have just updated my ubuntu and had to remove ROS melodic and install ROS noetic instead. I had changed the ~/.bashrc file and added the command line

source /opt/ros/melodic/setup.bash

so I wouldn't had to source my ROS everytime I open a new terminal. now that I have installed new ROS noetic, I changed the .bashrc file again and replaced the last line with:

source /opt/ros/noetic/setup.bash

but it won't work. I have to source my ROS every time I open a new terminal? any idea how to fix this?

edit retag flag offensive close merge delete

Comments

please post the last few lines of your current .bashrc by editing your question, copy&paste of the last few lines and formatting it using the preformatted text button (with 10101) on it. Thank you.

mgruhler gravatar image mgruhler  ( 2020-12-16 02:59:47 -0500 )edit