Ask Your Question
0

Rviz fuerte and master electric

asked 2012-06-08 02:51:58 -0600

LucaGhera gravatar image

updated 2012-06-08 04:52:11 -0600

joq gravatar image

Hi all,

I have a robot which is running ROS electric. On my macbook pro instead I have compiled Rviz fuerte (under osx Lion).

I set the ROS_MASTER on my mac and I'm able to communicate with the ROS Master. Now on rViz I'm can read all the topics (so I see the robot moving, the laser scans and so on). I can also read the topics by means of rostopic echo.

However I can't write on topics. More in details:

  • When I send a 2D nav goal from Lion I can see the message with rostopic on my mac but not on the robot.
  • If I try to send a 2D nav goal from ubuntu in virtual machine (still on my mac) I can see the message with rostopic on the robot by not on Lion.

Is it a known bug? Or isn't possible to have rviz (fuerte) working with rosmaster (electric)?

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-06-08 03:10:51 -0600

Lorenz gravatar image

updated 2012-06-08 03:11:25 -0600

This probably is neither a bug nor a problem with Fuerte vs. Electric. To me it looks like something is wrong with your network configuration. Have a look at this wiki page for diagnosing this kind of issues.

Since the robot cannot receive any data from your laptop, I guess its host name is not known to the robot, i.e. ping <hostname of your laptop> doesn't work on your robot. Try setting the environment ROS_IP on your laptop.

Sending data from the virtual machine is even more tricky. You'll probably have to set up bridging instead of a routing based network. When you can ping the IP of your virtual machine from your robot and you set ROS_IP inside it, then publishing from it should work.

edit flag offensive delete link more

Comments

@Lorenz Thanks! Now it works. I forgot to update the IP of my macbook on the robot. So that was the problem. The virtual machine worked well already. As you said you have to bridge the connection to the virtual machine!

LucaGhera gravatar imageLucaGhera ( 2012-06-08 06:23:45 -0600 )edit
0

answered 2012-06-08 04:51:09 -0600

joq gravatar image

Trying to combine different ROS versions into a single graph is a really bad idea.

While that may work in certain restricted instances, in general it will not and you should not expect the ROS community to support it.

The whole point of making ROS distributions is to create a large collection of stacks and packages that can interact reasonably smoothly.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-08 02:51:58 -0600

Seen: 416 times

Last updated: Jun 08 '12