AMCL Tuning

asked 2020-04-14 07:14:09 -0600

lunatic gravatar image

updated 2020-04-14 07:17:06 -0600

Hi, I have been struggling at tuning the amcl parameters. No matter how I tuned it the result is is not that ideal here. Below is my amcl config. I plotted the amcl poses into a path. Green is odom, red is amcl, blue is amcl_ekf. I understand that ekf has helped a lot in localising it but I would like to improve amcl too.

<param name="base_frame_id" value="base_footprint" />
<param name="odom_frame_id" value="odom" />
<param name="global_frame_id" value="map" />

<param name="tf_broadcast" value="false" />
<param name="use_map_topic" value="true" />
<param name="save_pose_rate" value="0.5" />

<param name="odom_model_type" value="diff-corrected" />
<param name="transform_tolerance" value="0.2" />
<param name="gui_publish_rate" value="13"/>
<param name="laser_max_beams" value="20"/>
<param name="laser_max_range" value="50"/>
<param name="min_particles" value="1000"/>
<param name="max_particles" value="3000"/>

<param name="update_min_d" value="0.005"/>
<param name="update_min_a" value="0.005"/>

<param name="kld_err" value="0.01"/>
<param name="kld_z" value="0.99"/>
<param name="odom_alpha1" value="0.005"/>
<param name="odom_alpha2" value="0.005"/>
<param name="odom_alpha3" value="0.010"/>
<param name="odom_alpha4" value="0.005"/>
<param name="odom_alpha5" value="0.1"/>
<param name="laser_z_hit" value="0.95"/>
<param name="laser_z_short" value="0.1"/> 
<param name="laser_z_max" value="0.05"/> 
<param name="laser_z_rand" value="0.05"/>
<param name="laser_sigma_hit" value="0.2"/>
<param name="laser_lambda_short" value="0.1"/>
<param name="laser_model_type" value="likelihood_field"/>
<param name="laser_likelihood_max_dist" value="10.0"/>

<param name="resample_interval" value="1"/>

<param name="initial_pose_x"            value="$(arg initial_pose_x)"/>
<param name="initial_pose_y"            value="$(arg initial_pose_y)"/>
<param name="initial_pose_a"            value="$(arg initial_pose_a)"/>

<param name="recovery_alpha_slow" value="0.0"/>
<param name="recovery_alpha_fast" value="0.0"/>
edit retag flag offensive close merge delete