Robot is misbehaving in rviz

asked 2020-04-07 09:11:31 -0500

Yash gravatar image

updated 2020-04-07 10:09:23 -0500

Hello Guys,

I have been developing a Mecanum Wheeled robot simulation using Gazebo and Rviz. I have written a URDF which you can see below. After this, a map was built using teleoperation and the gazebo plugin for Mecanum Robot. I used both gmapping and hector slam for this. The picture of the map is attached to this post. Then in rviz after sending the goal, I expect the robot to go to that position using global planner, dea/teb local planner whichever is selected in the launch file. Also, in the URDF mentioned below I have not attached the Mecanum plugin but it is used in my final urdf. This is just a snippet of the body and wheels.

But the problem I am facing is can be seen in the video attached below. The robot just stutters and does weird things like only the body moves and the wheels do not. Therefore, I think the problem is either with the URDF or move_base but I am not quite sure. Hence, I would really appreicate any help I get. Unfortunately I do not know how to attach a video to this and whether it is permitted or not. Hence I will attach some Images and I hope you guys get the gist of the problem.

Edit: Can someone please inform me how to upload images? The attachment button doesn't seem to work.

Thank You.

    <!-- Base Footprint Link and Joint Definition -->
<link name="base_footprint"/>

<joint name="base_joint" type="fixed">
    <parent link="base_footprint"/>
    <child link="base_link"/>
    <origin xyz="0 0 0.076" rpy="0 0 0"/>

<link name="base_link">
            <mesh filename="package://agv_description/meshes/Autonomous_Vehicle/V3_body_Assembly.stl" scale="0.01 0.01 0.01"/>
        <material name="blue"/>
        <origin xyz="0 0 0.01423" rpy="0 0 0" />

            <mesh filename="package://agv_description/meshes/Autonomous_Vehicle/V3_body_Assembly.stl" scale="0.01 0.01 0.01"/>
        <origin xyz="0 0 0.01423" rpy="0 0 0" />            

        <origin xyz="0.25 -0.25 0.15" rpy="0 0 0"/>
        <mass value="18.316"/>
        <inertia ixx="0.519" ixy="0.0" ixz="0.0"
                 iyy="0.519" iyz="0.0"


<!-- ************ Left Rear Wheel and Joint ********** -->
<link name="left_rear_wheel">

            <mesh filename="package://agv_description/meshes/Autonomous_Vehicle/V3_Wheel_Assembly_1.stl" scale="0.01 0.01 0.01"/>
        <material name="red"/>
        <!--origin xyz="0 -0.025 0" rpy="0 0 -3.142"/-->
        <!--origin xyz="0.076 0.1275 0.076" rpy="0 0 0"/-->
        <origin xyz="0 -0.0842 0" rpy="0 0 -3.142"/>

            <mesh filename="package://agv_description/meshes/Autonomous_Vehicle/V3_Wheel_Assembly_1.stl" scale="0.01 0.01 0.01"/>
        <!--origin xyz="0.076 0.1275 0.076" rpy="0 0 ...
edit retag flag offensive close merge delete


Can someone please tell me how do I add pictures to this? I have tried attaching the Image (png and jpg) but I cannot see it in the question

Yash gravatar image Yash  ( 2020-04-07 09:18:34 -0500 )edit

Can someone please inform me how to upload images? The attachment button doesn't seem to work.

That's because you did not have sufficient karma. As an anti-spam measure, attaching images to posts is not allowed for users with < 10 karma points.

I've give you sufficient karma, so you should be able to attach your screenshots now.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-07 09:40:34 -0500 )edit

Okay Thank You. I will try now

Yash gravatar image Yash  ( 2020-04-07 10:04:48 -0500 )edit

@gvdhoorn, The attachement button still doesn't work. I am trying to attach png images. I am selecting the image I want to attach, but then after hitting the 'OK' button, the image doesn't appear.

Yash gravatar image Yash  ( 2020-04-07 10:06:34 -0500 )edit

Could you try use the command: rosrun rqt_tf_tree rqt_tf_tree to visualize the tf tree? Using this you are able to find unconnected points.

Teo Cardoso gravatar image Teo Cardoso  ( 2020-04-07 12:47:52 -0500 )edit

@Teo Cardoso I did that and it seems that all the other links are connected to the base_link. Base_link is connected to base_footprint which is connected to odom.

Yash gravatar image Yash  ( 2020-04-07 22:49:27 -0500 )edit