Ask Your Question
0

rostopic not showing data electric

asked 2012-05-21 15:22:36 -0600

Blstinne gravatar image

I have two laptops running Ubuntu lucid and ROS electric. I have written three publishers in roscpp that are publishing input data to rostopics.

When running on one computer, I am able to see the topics and echo them to see the data being published.

For the second computer, I have set the ROS_MASTER_URI to the IP of the first computer, and when doing a rostopic list I am able to see the topics from the first computer. But when I rostopic echo, I do not see any of the data that is visible on the first computer.

I can ping back and forth, ssh and copy files, and I see the topic list change correctly as I start and kill my publishers. I do not know what the issue is. My ros_master_uri is set correctly, and the publishers are giving data to the topic. It just doesnt come through the wireless.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-05-21 17:46:06 -0600

updated 2012-05-21 17:47:58 -0600

My guess is that you don't have ROS_IP set correctly. A resolvable ROS_IP is required for the rostopic echo node to be fully connected with your publisher. You should be able to verify that the connection exists using rxgraph. You should also set ROS_IP on both machines.

You can read more about setting up your network here.

You can read more about ROS_IP here.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-21 15:22:36 -0600

Seen: 801 times

Last updated: May 21 '12