ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

SBC Environment Setup

asked 2020-02-18 02:05:33 -0500

shunta ito gravatar image


I got an trouble when I followed the instruction below.

link text Domain ID Allocation

I made a mistake when typing commands.

I wrote echo 'source ~/turtlebot3_ws/install/setp.bash' >> ~/.bashrc by mistake. (setup>>setp)

I wrote correct commands and rebooted, but

home/ubuntu/turtlebot3_ws/install/setp.bash: No such file or directory appears.

Do you know how to delete the history that I wrote the incorrect commands ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2020-02-18 04:04:41 -0500

marguedas gravatar image

What the echo 'source ~/turtlebot3_ws/install/setp.bash' >> ~/.bashrc command does is writing source ~/turtlebot3_ws/install/setp.bash at the end of the ~/.bashrc file.

To correct it you need to edit (with a text editor, e.g. nano) the ~/.bashrc file and modify the line from setp.bash to setup.bash

edit flag offensive delete link more


Thank you! The problem was solved.

shunta ito gravatar image shunta ito  ( 2020-02-18 06:48:13 -0500 )edit

As this solved the issue, can you please accept the answer by clicking the checkmark on the left so that this doesn't show up in the list of unanswered questions

marguedas gravatar image marguedas  ( 2020-02-18 07:14:38 -0500 )edit

Question Tools

1 follower


Asked: 2020-02-18 02:05:33 -0500

Seen: 114 times

Last updated: Feb 18 '20