Ask Your Question
0

RGBDSLAM Installation Problems

asked 2012-05-21 02:00:38 -0500

balunjones gravatar image

updated 2014-01-28 17:12:24 -0500

ngrennan gravatar image

I've been trying to install RGBDSLAM on Ubuntu 12 with ROS Fuerte. I know this is not currently supported, but the only error I have is that g2o seems to depend on eigen which is in the release (as eigen3) and is on my system, but I can't seem to get it to overcome this dependency.

Has anyone had any success with this install. Now trying with Ubuntu 11.10 and ROS electric. Still going on that one!


For starters,

rosmake --rosdep-install rgbdslam

doesn't work. However if you run

rosmake rgbdslam

I get:

[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['rgbdslam']                                
[ rosmake ] Logging to directory /home/ben/.ros/rosmake/rosmake_output-20120521-184019
[ rosmake ] Expanded args ['rgbdslam'] to:
['rgbdslam']                         
[rosmake-0] Starting >>> bullet [ make ]                                        
[rosmake-1] Starting >>> geometry_msgs [ make ]                                 
[rosmake-2] Starting >>> roslang [ make ]                                       
[rosmake-3] Starting >>> rosconsole [ make ]                                    
[rosmake-0] Finished <<< bullet ROS_NOBUILD in package bullet                   
[rosmake-2] Finished <<< roslang ROS_NOBUILD in package roslang
 No Makefile in package roslang
[rosmake-0] Starting >>> angles [ make ]                                        
[rosmake-2] Starting >>> roscpp [ make ]                                        
[rosmake-1] Finished <<< geometry_msgs ROS_NOBUILD in package geometry_msgs
 No Makefile in package geometry_msgs
[rosmake-1] Starting >>> sensor_msgs [ make ]                                   
[rosmake-3] Finished <<< rosconsole ROS_NOBUILD in package rosconsole
 No Makefile in package rosconsole
[rosmake-0] Finished <<< angles ROS_NOBUILD in package angles                   
[rosmake-2] Finished <<< roscpp ROS_NOBUILD in package roscpp
 No Makefile in package roscpp
[rosmake-0] Starting >>> rospy [ make ]                                         
[rosmake-2] Starting >>> roswtf [ make ]                                        
[rosmake-3] Starting >>> rostest [ make ]                                       
[rosmake-1] Finished <<< sensor_msgs ROS_NOBUILD in package sensor_msgs
 No Makefile in package sensor_msgs
[rosmake-0] Finished <<< rospy ROS_NOBUILD in package rospy
 No Makefile in package rospy
[rosmake-1] Starting >>> message_filters [ make ]                               
[rosmake-0] Starting >>> g2o [ make ]                                           
[rosmake-3] Finished <<< rostest ROS_NOBUILD in package rostest
 No Makefile in package rostest
[rosmake-2] Finished <<< roswtf ROS_NOBUILD in package roswtf
 No Makefile in package roswtf
[rosmake-2] Starting >>> std_msgs [ make ]                                      
[rosmake-1] Finished <<< message_filters ROS_NOBUILD in package message_filters
 No Makefile in package message_filters
[rosmake-3] Starting >>> rosbag [ make ]                                        
[rosmake-1] Starting >>> tf [ make ]                                            
[rosmake-3] Finished <<< rosbag ROS_NOBUILD in package rosbag
 No Makefile in package rosbag
[rosmake-2] Finished <<< std_msgs ROS_NOBUILD in package std_msgs
 No Makefile in package std_msgs
[rosmake-2] Starting >>> pcl [ make ]                                           
[rosmake-3] Starting >>> rosbuild [ make ]                                      
[rosmake-3] Finished <<< rosbuild ROS_NOBUILD in package rosbuild
 No Makefile in package rosbuild
[rosmake-3] Starting >>> roslib [ make ]                                        
[rosmake-3] Finished <<< roslib ROS_NOBUILD in package roslib
 No Makefile in package roslib
[rosmake-3] Starting >>> pluginlib [ make ]                                     
[rosmake-3] Finished <<< pluginlib ROS_NOBUILD in package pluginlib             
[rosmake-3] Starting >>> bond [ make ]                                          
[rosmake-1] Finished <<< tf ROS_NOBUILD in package tf                           
[rosmake-2] Finished <<< pcl ROS_NOBUILD in package pcl
 No Makefile in package pcl
[rosmake-1] Starting >>> smclib [ make ]                                        
[rosmake-3] Finished <<< bond ROS_NOBUILD in package bond                       
[rosmake-2] Starting >>> rosservice [ make ]                                    
[rosmake-3] Starting >>> common_rosdeps [ make ]                                
[rosmake-2] Finished <<< rosservice ROS_NOBUILD in package rosservice
 No Makefile in package rosservice
[rosmake-1] Finished <<< smclib ROS_NOBUILD in package smclib                   
[rosmake-1] Starting >>> bondcpp [ make ]                                       
[rosmake-3] Finished <<< common_rosdeps ROS_NOBUILD in package common_rosdeps   
[rosmake-2] Starting >>> dynamic_reconfigure [ make ]                           
[rosmake-3] Starting >>> opencv2 [ make ]                                       
[rosmake-2] Finished <<< dynamic_reconfigure ROS_NOBUILD in package dynamic_reconfigure
[rosmake-2] Starting >>> visualization_msgs [ make ]                            
[rosmake-2] Finished <<< visualization_msgs ROS_NOBUILD in package visualization_msgs
 No Makefile in package visualization_msgs
[rosmake-3] Finished <<< opencv2 ROS_NOBUILD in package opencv2                 
[rosmake-2] Starting >>> rgbdslam [ make ]                                      
[rosmake-1] Finished <<< bondcpp ROS_NOBUILD in package bondcpp                 
[rosmake-3] Starting >>> cv_bridge [ make ]                                     
[rosmake-1] Starting >>> nodelet ...
(more)
edit retag flag offensive close merge delete

Comments

Please post exact details of when you get a problem, e.g. errors. I would suspect that you only need to include the proper cmake macros to find eigen.

dornhege gravatar imagedornhege ( 2012-05-21 03:01:20 -0500 )edit

Although it's still no guarantee that there won't be more problems. Have you tried 2.1.1 and 2.1.2 in the g2o package?

dornhege gravatar imagedornhege ( 2012-05-21 08:15:45 -0500 )edit

How do you find those packages?

balunjones gravatar imagebalunjones ( 2012-05-21 10:22:06 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-05-21 22:08:39 -0500

karthik gravatar image

Try this. CMakeLists.txt should have the following lines in this place just above the rosbuild_genmsg().

#Eigen required    
find_package(Eigen REQUIRED)
include_directories(${EIGEN_INCLUDE_DIRS})

If Eigen is installed in the system this should work.

Hope it helps, Karthik

edit flag offensive delete link more
1

answered 2012-07-25 09:35:03 -0500

jerdman gravatar image

you can fix the eigen dependency by editing the manifest as shown here. I followed those directions, but am now stuck with the following error

CMake Error at CMakeLists.txt:103 (MESSAGE):
    SiftGPU cannot be compiled.  Returned: 2

Hope you have better luck.

edit flag offensive delete link more
1

answered 2012-07-30 06:01:22 -0500

Sudhan gravatar image

Try installing all this,

sudo apt-get install libglew1.5-dev libdevil-dev libsuitesparse-dev

sudo apt-get install libgsl0-dev

Also build g20 package and edit the manifest.xml to solve the eigen package problem.

I hope it should work.

cheers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-21 02:00:38 -0500

Seen: 1,904 times

Last updated: Jul 30 '12