Ask Your Question
0

Create_Autonomy Xbox Controller Gazebo Error

asked 2020-02-12 23:46:33 -0500

hannah1 gravatar image

updated 2020-02-12 23:47:53 -0500

Running this code: https://github.com/frankjoshua/create...

I have my robot up and running in gazebo. i can manually command it to move with the terminal window, however the xbox controller is not working and i get this error: [ERROR] [1581572040.895984, 213.209000]: Joystick has only 2 axes (indexed from 0), but #4 was referenced in config.

edit retag flag offensive close merge delete

Comments

what is your Gazebo version ?

Fetullah Atas gravatar image Fetullah Atas  ( 2020-02-13 02:14:53 -0500 )edit

Gazebo 7. Do you think I should upgrade or downgrade?

hannah1 gravatar image hannah1  ( 2020-02-13 08:21:42 -0500 )edit

Gazebo 7 have subversion , what is your full version ? , I remember one issue that had same error with yours , which was solved by upgrading to higher gazebo subversion , you may try that and see if that works

Fetullah Atas gravatar image Fetullah Atas  ( 2020-02-13 08:56:41 -0500 )edit

1 Answer

Sort by » oldest newest most voted
-1

answered 2020-02-15 17:46:58 -0500

hannah1 gravatar image

That must be it! I’m running gazebo 7.0 (which installed with kinetic). How to I upgrade to at least gazebo 7.8?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-02-12 23:46:33 -0500

Seen: 79 times

Last updated: Feb 15 '20