How to tell rosdep to skip installing package (installing ROS from source)? [closed]

asked 2019-11-14 05:37:25 -0600

ignite gravatar image

updated 2019-11-14 06:16:24 -0600

So I try to install ROS from source but rosdep seems to ask me to install several library dependencies inclusing libqt and libpcl-1.8 even when these libraries are already installed (Qt5 and pcl-1.9 was built from source, and installed to /opt/Qt5/ and /usr/local/include/pcl-1.9/ respectively).

w@laptop:~/mylib$ cd ros_catkin_ws/
w@laptop:~/mylib/ros_catkin_ws$ rosdep install --from-paths src --ignore-src --rosdistro kinetic
executing command [sudo -H apt-get install libqt5widgets5]
[sudo] password for w: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  cmake-data libjsoncpp1
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5svg5
Suggested packages:
  libqt5libqgtk2 qt5-image-formats-plugins qtwayland5
The following NEW packages will be installed:
  libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5svg5 libqt5widgets5
0 upgraded, 6 newly installed, 0 to remove and 18 not upgraded.
Need to get 0 B/7,204 kB of archives.
After this operation, 25.0 MB of additional disk space will be used.
Do you want to continue? [Y/n]


How should I tell rosdep to skip these libraries, use the ones already installed instead, or pass Qt5 and pcl-1.9 path to rosdep (similar to the way we pass CMAKE_PREFIX_PATH to CMake)?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by ignite
close date 2019-11-20 08:12:12.546110



I believe this is answered in #q188398.

If so, please close this question as a duplicate.

To make it extra clear: you specify a list of dependencies that rosdep should ignore by adding --skip-keys to the command line you use to invoke it. Be sure to list rosdepkeys, not package names used by Ubuntu/Debian/Your OS.

See also the documentation.

gvdhoorn gravatar image gvdhoorn  ( 2019-11-14 05:43:50 -0600 )edit

Thanks for pointing me out. I will keep this question open for a couple of days before closing it too early; will try that solution and see if it works.

ignite gravatar image ignite  ( 2019-11-14 05:49:41 -0600 )edit