turtlebot3 - roslaunch turtlebot3_bringup turtlebot3_robot.launch from a **service*

asked 2019-10-23 18:17:10 -0600

updated 2019-10-23 18:49:11 -0600

ahendrix gravatar image

Hello, I am a novate in ROS and I am trying to run the roslaunch turtlebot3_bringup turtlebot3_robot.launch from a service to load at the start of the robot but it does not work. If I see the status of the service it does not show any errors. I am doing something wrong ? This is possible ?

pi@raspberrypi:~/catkin_ws/src/turtlebot3/turtlebot3_bringup/launch $ sudo systemctl status robotin.service
● robotin.service - start roscore
   Loaded: loaded (/etc/systemd/system/robotin.service; disabled; vendor preset:
   Active: active (running) since Wed 2019-10-23 17:01:07 CST; 43s ago
 Main PID: 1410 (rosCoreService.)
    Tasks: 31 (limit: 4915)
   CGroup: /system.slice/robotin.service
           ├─1410 /bin/bash /usr/local/bin/rosCoreService.sh
           ├─1467 /usr/bin/python /opt/ros/kinetic/bin/roslaunch turtlebot3_brin
           ├─1480 /usr/bin/python /opt/ros/kinetic/bin/rosmaster --core -p 11311
           ├─1493 /opt/ros/kinetic/lib/rosout/rosout __name:=rosout __log:=/root
           ├─1498 python /opt/ros/kinetic/lib/rosserial_python/serial_node.py __
           ├─1507 /home/pi/catkin_ws/devel/lib/hls_lfcd_lds_driver/hlds_laser_pu
           └─1512 /home/pi/catkin_ws/devel/lib/turtlebot3_bringup/turtlebot3_dia

Oct 23 17:01:07 raspberrypi systemd[1]: Started start roscore.
Oct 23 17:01:40 raspberrypi rosCoreService.sh[1410]: the rosdep view is empty: c
lines 1-16/16 (END)

I appreciate your help

edit retag flag offensive close merge delete

Comments

It looks like the roscore is running. Can you describe what you expect to be happening, and what you observe that makes you think it is not working?

ahendrix gravatar imageahendrix ( 2019-10-23 18:51:01 -0600 )edit

Thank you, When I run the rostopic list command, I only list this: / rosout / rosout_agg

So I have errors in rviz (Global Status, RobotModel, Costmap) when I run roslaunch turtlebot3_navigation

BrunoCoto gravatar imageBrunoCoto ( 2019-10-23 19:07:18 -0600 )edit