[Ubuntu 16.04] Inability to run MoveIt tutorial

asked 2019-10-03 05:39:31 -0500

salmon gravatar image

I'm trying to follow the tutorial but rosdep is not functioning.

Running rosdep install -y --from-paths . --ignore-src --rosdistro kinetic

throws up the following error message:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: moveit_tutorials: No definition of [joy] for OS [debian]

There are a couple of forum posts from various years but I've tried solutions including installing rosdep from source but this hasn't worked. I've checked out the correct branches for my ROS distribution from Github.

edit retag flag offensive close merge delete

Comments

Hello, Can you give the output of the command : uname -a ? Also, maybe it will work if you give rosdep an OS override argument : rosdep install -y --from-paths . --ignore-src --rosdistro kinetic --os=ubuntu:xenial

lmathieu gravatar imagelmathieu ( 2019-10-03 09:14:48 -0500 )edit

If this is really Ubuntu Xenial, then there is a chance the OP installed UpstreamPackages.

@salmon: what is the output of rosversion -d?

gvdhoorn gravatar imagegvdhoorn ( 2019-10-04 08:12:26 -0500 )edit