Ask Your Question
1

Autoware : Unable to complete the demo

asked 2019-10-03 03:06:23 -0500

Mackou gravatar image

updated 2019-10-03 05:00:11 -0500

Hello.

  • Autoware version : 1.12.0
  • ROS Version : Melodic
  • Autoware installed from Docker
  • Docker version 19.03.2, build 6a30dfc

I am trying to run the demo of autoware here : https://gitlab.com/autowarefoundation...

But I am experiencing a lot of problems.

First of all, I download the files, create a .autoware in my personal home and extract the files there.

I start autoware by running the run.sh file, I am now connected with the autoware user 'in' the docker container.

But then the first instruction is to move to the directory autoware.ai which doesn't exist !

The right folder seems to be

/home/autoware/Autoware

Then I source the setup.bash file.

I start the runtime manager with

roslaunch runtime_manager runtime_manager.launch

Then I move to the simulation tab and try to load the bag file from ~/.autoware but the folder doesn't contain my files...

I am truly lost, and I can't see what I did wrong. Thanks for the help !


[Edit] I made it working by using ~/Autoware instead of ~/autoware.ai (In the docker machine)

Then I copied the ~/.autoware from the host to the docker machine and It's fine.

Do you think I did something wrong or the documentation maybe deserves a pull request ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-10-10 07:17:47 -0500

Maximus5684 gravatar image

It does look like the demo instructions need some updating. I will put that on my list and report back when they are updated. We are in the middle of the 1.13.0 release process right now so it may take a little while.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-03 03:06:23 -0500

Seen: 34 times

Last updated: Oct 10