Ask Your Question
1

Problem in make for qt_create(ed) package

asked 2012-05-03 01:47:07 -0500

updated 2014-01-28 17:12:11 -0500

ngrennan gravatar image

Hello,

I tried to follow this tutorial link:here

After creating the qt package by running this line:

rosrun qt_create roscreate-qt-pkg qdude

And after I run the make:

make

I got this error:

CMake Error at CMakeLists.txt:51 (QT4_ADD_RESOURCES): Unknown CMake command "QT4_ADD_RESOURCES".

Did I miss something. For your information, I have installed Qt Creator IDE, which mean, the Qt library is in my system, right?

I am quite new in Ubuntu and I apologise if this question is redundant.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-01 09:41:40 -0500

130s gravatar image

Although the OP is kind of old, and qt_creator is deprecated from fuerte, just trying to answer for the record (esp. there seem not an alternative as of today).

Not entirely sure but 1st of all, have you added the path of your package to $ROS_PACKAGE_PATH? Also, is Qt really installed? What does the following command return?

$ rospack find %YOUR_PACKAGE_NAME%
$ qmake --version

If something in the result looks wrong, fix it first.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-03 01:47:07 -0500

Seen: 948 times

Last updated: Nov 01 '12