Can't install ros-kinetic-destop-full for unmet dependencies

asked 2019-08-20 22:15:06 -0600

YancenBOB gravatar image

updated 2019-08-21 03:22:10 -0600

Backgrounds:
My Ubuntu 16.04-64bit (in the vmware worksation 12) is broken and I reinstalled it again. Now I need to install ros kinetic. I follow the tutorials (http://wiki.ros.org/kinetic/Installat...). When I try the step 1.4 to install the ros-kinetic-desktop-full, I meet the question about unmet dependencies

Question

When I try the commend sudo apt-get install ros-kinetic-desktop-full, the information is that:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-kinetic-desktop-full : Depends: ros-kinetic-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I am sure that I try many times to install the ros kinetic and even I had a successful experience. In that time, I followed the tutorials and it made sense.

Details:

I show you the details when I follow the tutorials

1.1 I check the Ubuntu repositories image description

1.2 and 1.3 I use the official mirror and set the key

cyx@cyx-virtual-machine:~$ sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'
[sudo] password for cyx: 
cyx@cyx-virtual-machine:~$ sudo apt-key adv --keyserver 'hkp://keyserver.ubuntu.com:80' --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654
Executing: /tmp/tmp.yKbwOB4usX/gpg.1.sh --keyserver
hkp://keyserver.ubuntu.com:80
--recv-key
C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654
gpg: requesting key AB17C654 from hkp server keyserver.ubuntu.com
gpg: key AB17C654: "Open Robotics <info@osrfoundation.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

1.4 I try the update

Hit:1 http://packages.ros.org/ros-shadow-fixed/ubuntu xenial InRelease
Ign:2 http://cz.archive.ubuntu.com/ubuntu trusty InRelease                     
Hit:3 http://cn.archive.ubuntu.com/ubuntu xenial InRelease                     
Hit:4 http://security.ubuntu.com/ubuntu xenial-security InRelease              
Hit:5 http://packages.ros.org/ros/ubuntu xenial InRelease                      
Hit:6 http://cz.archive.ubuntu.com/ubuntu trusty Release                       
Hit:7 http://cn.archive.ubuntu.com/ubuntu xenial-updates InRelease       
Hit:9 http://cn.archive.ubuntu.com/ubuntu xenial-backports InRelease
Reading package lists... Done

1.4 again I meet the question. It is the same as I copy above that the information is that The following packages have unmet dependencies: ros-kinetic-desktop-full : Depends: ros-kinetic-simulators but it is not going to be installed

What I have tried:

I search the solutions online and unfortunately they are not in work:

I tried it in ASKUBUNTU but it didn't work(https://askubuntu.com/questions/... Some one said to check the update settings and I check that it is no problem.
image description

I check that I have not install the gazebo

cyx@cyx-virtual-machine:~$ gazebo --version
The program 'gazebo' is currently not installed. You can install it by typing:
sudo apt install ...
(more)
edit retag flag offensive close merge delete

Comments

This is probably a problem about having held broken packages. There is a good discussion of this and several solutions discussed here. Let you know how you get on.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2019-08-21 04:07:28 -0600 )edit

@PeteBlackerThe3rd Thanks for your advice. I tried some methods like -f install, sudo aptitutde. They are not work for me and I try to install ros-kinetic-desktop, not for full. It is also failed. But the link has many discussion solutions and I will try them. Thank you!

YancenBOB gravatar imageYancenBOB ( 2019-08-22 22:15:09 -0600 )edit