Exe file not updated after catkin_make

asked 2019-08-09 18:12:37 -0500

jason gravatar image

Hello, I have a ROS sworkspace and there is a cpp file. In that cpp file, I changed the published message for example from "3, 0, 2" to "0,0,2". And catkin_make it. The compilation succeed. Then I use roslaunch to launch this cpp file related node. However, after I use rostopic echo to check the published message, it is still "3,0,2", it doesn't change even the code was changed and recompiled. I also tried source devel/setup.bash, still the same. While means the very first exe file of this cpp file was not updated. I know delete the build folder will make it work. But is there anything I am missing? I believe there should be other solutions.

edit retag flag offensive close merge delete

Comments

Are you sure that you're changing/running the correct node? Also, are you using Windows (I see that you're mentioning an exe file)?

jayess gravatar imagejayess ( 2019-08-09 19:10:05 -0500 )edit

Yes, it is the correct file. I succeed once without deleting build folder. And I am using the raspberry pi 3. Sorry for the exe file, I mant executable file. I am wondering is it because the time? Every time the pi reboots, I need to reset the time. Maybe I didn't set time when first compile this node?

jason gravatar imagejason ( 2019-08-09 19:33:53 -0500 )edit