Talker listener connection only works one way

asked 2019-07-30 15:45:07 -0500

http://wiki.ros.org/ROS/Tutorials/Mul...

I was following the above tutorial which is pretty simple. I have two computers one with ROS melodic and another with ROS kinetic. From my understanding that should not affect the results. When I run roscore on melodic and make it the listener I do not get any information from the kinetic computer running the talker.py file. However, when I run roscore and the listener.py file on melodic I get loads of information supposedly form the talker.py file even when I have yet to run it. Help?? The connection is good between both computers.

edit retag flag offensive close merge delete

Comments

Difficulties getting things to work bidirectionally are almost always caused by not setting ROS_IPor having a working DNS for all involved hosts.

To test: set ROS_IPon both computers to the IP of the respective computer. Then start roscore and try running your scripts again.

Note: you'll have to set ROS_IP in each terminal again, unless you add it to your .bashrc (or similar shell configuration script).

gvdhoorn gravatar imagegvdhoorn ( 2019-08-01 07:06:12 -0500 )edit

Please also note: there are many, many duplicates of this question here on this site.

I would recommend you try using Google: your keywords here site:answers.ros.org.

gvdhoorn gravatar imagegvdhoorn ( 2019-08-01 07:06:49 -0500 )edit