ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

Any OpenCV 3 with Kinetic?

asked 2019-07-12 10:27:59 -0500

cjk11091 gravatar image

updated 2019-07-12 10:59:58 -0500

Based on the recommended platforms found here:

http://www.ros.org/reps/rep-0003.html

Can any OpenCV 3 be installed with Kinetic? My project leans more toward OpenCV than ROS so I'd like to get OpenCV 3.4.6 (or any 3.4 really) if possible - I read somewhere the default with Kinetic was 3.1 or 3.2.

Also there is no compatibility with OpenCV 4.1 for any ROS distribution, correct?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-07-12 13:09:02 -0500

daniel_dsouza gravatar image

updated 2019-07-12 13:11:02 -0500

I believe that Kinetic comes with OpenCV 3.2 or 3.3 by default.

You can use newer versions of OpenCV with ROS, but you will have to modify and compile any other ROS packages which use OpenCV to use the same version you compiled.

So far this is no compatibility for OpenCV 4.1 even for Melodic or Dashing. I took a brief stab at building the package for OpenCV 4.1, but it wasn't as simple as upgrading between OpenCV 3 versions. You may be able to build OpenCV from scratch on each system, and then modify/recompile the other ROS packages that depend on OpenCV.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2019-07-12 10:27:59 -0500

Seen: 180 times

Last updated: Jul 12 '19