Remote node running on/off

asked 2019-07-02 04:09:35 -0600

iabadia gravatar image

Hi,

I am running a node on a remote machine but the node continuously goes on and off.

I am using a dedicated wired network and ROS_IP and ROS_MASTER_URI are specified for both machines in the env files. ROS Kinetic is being used on Ubuntu 16.04 for both machines.

The setup is very simple: from machine-A I run a roslaunch file including just the node to be executed on remote machine-B. The remote node cannot be any simpler, it just publishes a fixed size array of float data to a topic at a specified rate. The communication between machine-A and machine-B seems to be working fine (ping and ssh work on both directions). The remote node starts to run but then it suddenly stops (for about ~10s), then it runs again (for about ~1s), then it stops... and so on.

This on/off behaviour is reflected running rqt_gui: it shows that during the stop-period the CPU % consumed by the node is 0, while it goes to ~5% at the running-period.

If the node is launched locally there's no problem with it, so I guess it is not a problem of how the node is implemented (actually, I have tried with other nodes and the same thing happens). Also, the problem persists regardless the specified publishing rate (I have checked for 1Hz and 500Hz and the behaviour is the same).

Any ideas on where the problem might come from and what is actually going on?? Please, do not hesitate if more info is needed to solve this.

Thanks,

Ignacio

edit retag flag offensive close merge delete