Ask Your Question
0

installing vector_map_converter Autoware

asked 2019-06-03 03:13:02 -0500

jose.rincon gravatar image

updated 2019-06-06 01:56:48 -0500

jayess gravatar image

Hi,

I am trying to install the vector_map_converter tool to transform maps from lanelet2 to autoware, however it is not clear how exactly I should do this, the instructions say:

cd Autoware/
git submodule update --init --recursive
cd ros/
./colcon_release

When I clone the repo and go inside Autoware folder to execute git submodule update --init --recursive the package for the vector_map_converter dissapears. . Now, I am also not sure why the colcon_release is used instead of the run.sh or the build like the Autoware instructions says.

If I try to run the colcon_release I get the following errors:

[0.344s] ERROR:colcon.colcon_core.entry_point:Exception loading extension 'colcon_core.package_identification.python': No module named 'setuptools.config', 'setuptools' needs to be at least version 30.3.0, if a newer version is not available from the package manager use 'pip3 install -U setuptools' to update to the latest version
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/colcon_core/entry_point.py", line 98, in load_entry_points
    extension_type = load_entry_point(entry_point)
File "/usr/lib/python3/dist-packages/colcon_core/entry_point.py", line 140, in load_entry_point
    return entry_point.load()
File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2229, in load
    return self.resolve()
File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2235, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "/usr/lib/python3/dist-packages/colcon_core/package_identification/python.py", line 12, in <module>
    from setuptools.config import read_configuration
ImportError: No module named 'setuptools.config', 'setuptools' needs to be at least version 30.3.0, if a newer version is not available from the package manager use 'pip3 install -U setuptools' to update to the latest version

[0.350s] ERROR:colcon.colcon_core.entry_point:Exception loading extension 'colcon_core.package_identification.python_setup_py': No module named 'setuptools.config', 'setuptools' needs to be at least version 30.3.0, if a newer version is not available from the package manager use 'pip3 install -U setuptools' to update to the latest version
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/colcon_core/entry_point.py", line 98, in load_entry_points
    extension_type = load_entry_point(entry_point)
File "/usr/lib/python3/dist-packages/colcon_core/entry_point.py", line 140, in load_entry_point
    return entry_point.load()
File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2229, in load
    return self.resolve()
File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2235, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "/usr/lib/python3/dist-packages/colcon_python_setup_py/package_identification/python_setup_py.py", line 20, in <module>
    from colcon_core.package_identification.python import \
File "/usr/lib/python3/dist-packages/colcon_core/package_identification/python.py", line 12, in <module>
    from setuptools.config import read_configuration
ImportError: No module named 'setuptools.config', 'setuptools' needs to be at least version 30.3.0, if a newer version is not available from the package manager use 'pip3 install -U setuptools' to update to the latest version

[0.352s] ERROR:colcon.colcon_core.entry_point:Exception loading extension 'colcon_core.package_identification.ros': No module named 'setuptools.config', 'setuptools' needs to be at least version 30.3.0, if a newer version is not ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-03 03:43:30 -0500

Masaya Kataoka gravatar image

updated 2019-06-06 01:57:46 -0500

jayess gravatar image

In your error log, this error occurs from setuptools.

No module named 'setuptools.config', 'setuptools' needs to be at least version 30.3.0, if a newer version is not available from the package manager use 'pip3 install -U setuptools' to update to the latest version Traceback (most recent call last): File "/usr/lib/python3/dist-packages/colcon_core/entry_point.py", line 98, in load_entry_points extension_type =

It seems setuptools and colcon did not install in correct way.

edit flag offensive delete link more

Comments

Thank you! I updated the setuptools and reinstalled colcon_core but now I have different errors...i updated my original question.

jose.rincon gravatar imagejose.rincon ( 2019-06-03 04:51:35 -0500 )edit
1

The instruction was very brief since the branch was meant for temporal use until it is merged into Autoware official repository. I have updated instructions in more details. Please follow the new instruction: https://github.com/mitsudome-r/Autowa...

mitsudome-r gravatar imagemitsudome-r ( 2019-06-05 21:24:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-06-03 03:13:02 -0500

Seen: 92 times

Last updated: Jun 06