Ask Your Question
0

ROS2 for Win32 (x86): How to make colcon call cmake without "Win64"?

asked 2019-05-29 04:19:20 -0500

marossa gravatar image

Hi,

for a couple of days now, I've been trying to compile ROS2 for x86 under Windows. Because of other dependecies, I can't use x64. I tried a lot of stuff on my Windows 10 64bit machine that didn't work (i.e. recompile all necessary stuff for x86 and so on).

Now I'm working in a vanilla Windows 10 32bit VM and one problem seems to be, that I colcon always calls cmake with "Visual Studio 15 2017 Win64" and I can't change that. I tried calling colcon witn "--cmake-args -DCMAKE_CXX_FLAGS=-m32" which did not work either.

What I did on the vanilla Win10 32bit VM:

My questions are:

  1. What is the best way to compile ROS2 for Win32?
  2. How do I make colcon call cmake with "Visual Studio 15 2017" without "Win64"?

Thank you very much

Marossa

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-05-29 09:43:27 -0500

sloretz gravatar image

You'll likely need to modify colcon. It has a hardcoded list of supported visual studio versions.

https://github.com/colcon/colcon-cmak...

It seems like it would need an option to change the target platform name https://cmake.org/cmake/help/latest/g... . I recommend opening a PR or issue on https://github.com/colcon/colcon-cmake

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-05-29 03:21:46 -0500

Seen: 41 times

Last updated: May 29