Ask Your Question
0

Why does Autoware not show activity on all cores?

asked 2019-05-08 08:39:57 -0500

kishore gravatar image

Hello

I am running the ROSBAG demo in the v1.10.0 docker image running on Ubuntu 16.04 Machine which has 16 cores. htop utility shows activity on all cores but the CPU bars on the ARM shows only activity on CPU0. Am I missing something?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-09 03:00:34 -0500

sgermanserrano gravatar image

Are you running the demo? If that is the case you might need to enable the multithreaded mode for the ndt_matching node

edit flag offensive delete link more

Comments

Hello sgermanserrano

Thanks for the response. Yes I am trying to run the demo as per https://github.com/CPFL/Autoware/wiki... Is this the multithreaded mode you mean? Screenshot : https://pasteboard.co/IdTqiBu.png This did not help.

kishore gravatar image kishore  ( 2019-05-09 06:44:56 -0500 )edit

I mean in /ros/src/computing/perception/localization/packages/lidar_localizer/launch/ndt_matching.launch you can use the multithreaded implementation by setting the method_type to 3

sgermanserrano gravatar image sgermanserrano  ( 2019-05-09 06:58:37 -0500 )edit

My bad, that change did not help. I see a good CPU activity on all all cores with htop utility even inside the container when the simulation is on. Only that the ARM interface does not update the activity bars other than CPU0. Where does it read the information from ? Could it be anything to do with permissions?

kishore gravatar image kishore  ( 2019-05-09 09:04:13 -0500 )edit

facing same probelem

elnino_009 gravatar image elnino_009  ( 2020-03-10 03:44:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-05-08 08:39:20 -0500

Seen: 220 times

Last updated: May 08 '19