Cannot rostopic echo remote roscore

asked 2019-05-02 19:10:51 -0600

hardyn gravatar image

updated 2019-05-06 12:56:36 -0600

I have looked though most of the available online guides to rostopic echo a roscore running on a remote machine, but the standard suggestions are not helping

I have configured the ROS_MASTER_URI=192.168.0.109:11311 (the IP of the roscore) and am able to view the topics but not the messages. (I can view the mesage on the roscore machine).

The roscore machine also has its ROS_MASTER_URI=192.168.0.109:11311 (its own Ip).

The viewer has been installed with ROS desktop the roscore machine is headless with ROS basic; I wouldn't think it matters, but figured I would mention it.

Both computers have been configured with static IPs.

I have tried both the ROS_IP and ROS_HOST variables with no improvement.

Any help would be appreciated.

**Update: We had been running the application using robot_upstart, and it seems that the application is coming-up with incorrect or non-existent environment variables. When run manually, roslaunch, everything works as expected. It appears the the gotcha is robot_upstart.

It seems that there is some provision to make system configuration modifications using the --setup argument, however I am not having any breakthroughs there either. I suspect I will have to find another/open a new thread as I think I understand where the difficulty is now.

Thanks for the help.

edit retag flag offensive close merge delete

Comments

1

Saying what you set the ROS_IP and ROS_HOSTNAME to, and on what machines would help to debug this. Incorrect setting of these variables is a very common mistake that can cause the exact issue you are describing

jarvisschultz gravatar image jarvisschultz  ( 2019-05-02 19:16:03 -0600 )edit

The most common issue is: setting ROS_HOSTNAME or ROS_MASTER_URI to a hostname without a way for the machines to resolve the hostnames into IPs (or setting ROS_IP to a hostname, instead of an IP). @hardyn: note that if you have both ROS_IP and ROS_HOSTNAME, ROS_HOSTNAME will take precedence.

In any case we'll need more information, as @jarvisschultz already writes.

gvdhoorn gravatar image gvdhoorn  ( 2019-05-03 02:12:57 -0600 )edit