ROSSerial: Unable to sync: Teensy 3.6

asked 2019-04-07 11:40:06 -0500

THLL gravatar image

Using rosserial I am Unable to sync with a Teensy 3.6 board. Getting the [ERROR] "Unable to sync with device". I am using the rosserial_arduino Hello_world tutorial. The teensy has the hello world example, with the (#define USE_TEENSY_HW_SERIAL). Compiles fine. As well I can program the teensy from the pi fine too so its not a hardware connection issue.

Things I have tried so far

  • changing the baud rate on the arduino hardware.h file, (57600 to 115200)

  • Used command to match baud $ rosrun rosserial_python serial_node.py _baud:=115200 _port:=/dev/ttyACM0

  • Originally tried the default 57600 baud rate for both
  • Using same port I programmed it with, ttyACM0
  • As well closed out the arduino program in case their was already a serial connection to it
  • Works with a regular arduino uno but I need to use the teensy for this project

Raspberry pi 3 - Ubuntu 16.04 - ROS Kinetic

edit retag flag offensive close merge delete