Ask Your Question
0

Map_server could not open /home/test_map.yaml. [closed]

asked 2019-03-24 22:13:17 -0500

parzival gravatar image

I'm using a package called Chefbot, which has packages to run a differential drive autonomously using SLAM. However when I run the command: roslaunch chefbot_bringup amcl_demo.launch map_file:=/home/test_map.yaml

I get an error: [ERROR] [1553483186.539747153]: Map_server could not open /home/test_map.yaml. I read previous questions about the same, and for most of them the problem was solved by adding a '/' before the home directory. But I still get this error. I've checked that the map test_map exists. Please help.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by parzival
close date 2019-06-06 07:11:48.874863

Comments

Hi,

Can you please edit the question with the output of

ls -l /home/test_map.yaml
janindu gravatar imagejanindu ( 2019-03-25 00:15:25 -0500 )edit
1

Because ideally the path should be something like

/home/user_name/test_map.yaml
janindu gravatar imagejanindu ( 2019-03-25 00:16:21 -0500 )edit

Thanks a lot! That worked.

parzival gravatar imageparzival ( 2019-03-25 01:07:29 -0500 )edit

No prob. You should add how you solved the problem as an answer, accept it and close this question.

janindu gravatar imagejanindu ( 2019-03-26 01:14:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-28 23:56:11 -0500

parzival gravatar image

The path should be /home/username/map.yaml and not /home/map.yaml.

Also make sure there's a '/' before home.

This should do the job.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-03-24 22:13:17 -0500

Seen: 127 times

Last updated: Mar 28