Fedora 29: 'class_loader' tried to find library '-lpthread' [closed]

asked 2019-03-22 15:07:12 -0600

0novanta gravatar image

updated 2019-03-25 04:24:15 -0600

gvdhoorn gravatar image

I'd like to install ROS Kinetic Kame from here on my Fedora 29 laptop.

So I've found this guide which should work with Fedora too, even though I get that installing the program on Ubuntu would be much easier, but I don't have the chance to do so.

Anyway, I follow the guide and when I run this command ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release it stops with an error:

Project 'class_loader' tried to find library '-lpthread'.  The library is
  neither a target nor built/installed properly.  Did you compile project
  'class_loader'? Did you find_package() it before the subdirectory
  containing its code is included?

I don't know what to do, I've tried many things without any improvements. Are there any other solution apart from installing on Ubuntu or solving this issue that could get me ROS Kinetic to work?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by gvdhoorn
close date 2019-03-25 04:23:58.717286

Comments

You might want to look at #q311753

christophebedard gravatar image christophebedard  ( 2019-03-23 07:16:18 -0600 )edit

This indeed looks like a duplicate of #q311753.

gvdhoorn gravatar image gvdhoorn  ( 2019-03-25 04:24:35 -0600 )edit