Ask Your Question
1

rf2o won't work

asked 2019-03-10 08:52:17 -0500

Mr-Xavier gravatar image

Hi, I tried to use rf2o_laser_odometry packages but I was not able to make it work. When I launch it, I meet some problem like this [rf2o] ERROR: Eigensolver couldn't find a solution. Pose is not updated.

This is my launch file

<launch>
<node pkg="tf" type="static_transform_publisher" name="base_link2laser_link" args=" 0.07 0.0 0.0 0.0 0.0 0.0 /base_link /laser 10"/>
<node pkg="rf2o_laser_odometry" type="rf2o_laser_odometry_node" name="rf2o_laser_odometry" output="screen">
<param name="laser_scan_topic" value="/scan"/>        
<param name="odom_topic" value="/odom_rf2o" />             
<param name="publish_tf" value="true" />                   
<param name="base_frame_id" value="/base_link"/>            
<param name="odom_frame_id" value="/odom" />             
<param name="init_pose_from_topic" value=" " />
<param name="freq" value="6.0"/>                       
<param name="verbose" value="true" />        
</node>
</launch>

Anyone knows what the problem is and how to solve it?

edit retag flag offensive close merge delete

Comments

I have the same problem. Please support me if you have any solutions. Thank in advanced.

dvc97 gravatar image dvc97  ( 2019-03-14 03:52:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-12-21 02:32:19 -0500

Hi I found this solution hope it helps.

official repo issues : https://github.com/MAPIRlab/rf2o_lase...

solution : https://github.com/tianb03/rf2o_laser...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-03-10 08:52:17 -0500

Seen: 378 times

Last updated: Dec 21 '20