ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

catkin_prepare_release --bump minor fails

asked 2019-03-01 05:54:18 -0600

elcinerdogan gravatar image

updated 2019-03-01 06:10:59 -0600

gvdhoorn gravatar image

Currently, I'm trying to release my package for the first time using bloom.

I followed this guide . I indexed my package in /kinetic/distribution.yaml (firstly, on master branch), that passed. After that, I made pre-release tests and run ./ command at the end. Until now, everything is fine, I didn't met any fail.

After that, I generated CHANGELOG.rst by running; $ catkin_generate_changelog

As stated here (go to Step 2.1), I changed the CHANGELOG.rst and made the version 0.0.1. After that, I commit my changelog as;

But now I'm getting this error when I running $ catkin_prepare_release --bump minor;

Prepare the source repository for a release.
Repository type: git
Found packages: indoor_localization
Prepare release of version '0.1.0' [Y/n]?y
Trying to push to remote repository (dry run)...

Could not determine git remote: Command '['/usr/bin/git', 'config', '--get', u'branch.master.remote']' returned non-zero exit status 1

May be the branch 'master' is not tracking a remote branch?

I am very newbie in Git. What should I do? Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-03-01 09:42:15 -0600

nuclearsandwich gravatar image

I'm not too familiar with the internals for catkin_prepare_release but it looks like the tool is trying to determine the remote repository from the local branch, and is unable to do so. Git has a feature called Tracking Branches (see docs

If you're new to git, your remote is likely configured as origin, you can list remotes with the command git remote -v to check each origin name and its urls.

To set up your local master branch as a tracking branch for the master branch on the origin remote, you can run the command git branch master --set-upstream-to origin/master.

That should at least get you past the current issue.

edit flag offensive delete link more

Question Tools


Asked: 2019-03-01 05:54:18 -0600

Seen: 212 times

Last updated: Mar 01 '19