RPLIDAR A1 scan error while using rplidar_ros

asked 2019-02-01 04:20:08 -0600

ameykasar gravatar image

updated 2019-02-01 04:21:06 -0600

I am getting the following error while using RPLIDAR A1 and rplidar_ros package on Ubuntu 16.04 and ROS Kinetic. When I use roslaunch rplidar_ros test_rplidar.launch I get:

Scan mode `Sensitivity' is not supported by lidar
supported modes:
[ERROR] [1549015837.483212801]:     Standard: max_distance: 12.0 m, Point number: 2.0K
[ERROR] [1549015837.483229470]:     Express: max_distance: 12.0 m, Point number: 4.0K
[ERROR] [1549015837.483247611]:     Boost: max_distance: 12.0 m, Point number: 8.0K
[ERROR] [1549015837.483264352]: Can not start scan: 80008001!

What is the meaning of this? Is my RPLIDAR unit faulty?

edit retag flag offensive close merge delete


Have you tried running in standard mode ? Add this to your launch file :

<param name="scan_mode"           type="string"  value="Standard"/>
Delb gravatar image Delb  ( 2019-02-01 04:54:24 -0600 )edit

The RPLidar ROS node queries the hardware to find out which modes are available and in your case Sensitivity is not one of them.

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2019-02-01 05:50:44 -0600 )edit

so ? how do you fix this ? this used to work with ROS 1

phil123456 gravatar image phil123456  ( 2023-08-01 15:42:32 -0600 )edit

oh yeah I made it work

phil123456 gravatar image phil123456  ( 2023-08-02 11:52:44 -0600 )edit