ETH Modular sensor fusion framework fails to launch

asked 2018-12-12 20:48:44 -0600

unknowntoyou gravatar image

updated 2018-12-13 17:47:19 -0600

I am running ROS Kinetic on Ubuntu Xenial on an x86_64, with kernel 4.15.0-29-generic. I am trying to follow the following tutorial: http://wiki.ros.org/ethzasl_sensor_fu...

I followed all the steps to compile the framework as mentioned in the tutorial and could not make it work. So I used the additional packages mentioned and compiled all 4 of them:

https://github.com/catkin/catkin_simple
https://github.com/ethz-asl/glog_catkin
https://github.com/ethz-asl/asctec_mav_framework
https://github.com/ethz-asl/ethzasl_msf

which seems to be more successful. However, when I try to launch the package mentioned (viconpos_sensor), I keep getting the following error:

[viconpos_sensor.launch] is not a launch file name The traceback for the exception was written to the log file

Is it a compilation issue? Did I not set everything up correctly? Here is my environment:

ROS_ROOT=/opt/ros/kinetic/share/ros
ROS_PACKAGE_PATH=/home/yukti/Desktop/MSF_PACKAGE/catkin_simple-master:/home/yukti/catkin_ws/src:/opt/ros/kinetic/share
ROS_MASTER_URI=http://localhost:11311
ROS_VERSION=1
ROS_SPACE=/home/yukti/ros/rosbuild
ROSLISP_PACKAGE_DIRECTORIES=/home/yukti/Desktop/MSF_PACKAGE/devel/share/common-lisp:/home/yukti/catkin_ws/devel/share/common-lisp
ROS_DISTRO=kinetic
ROS_ETC_DIR=/opt/ros/kinetic/etc/ros

Some more information that would help replicate the bug is as follows: i have a master folder MSF_PACKAGE on my desktop that has the aforementioned packages listed within it. And I have set up my catkin workspace. Here is how I tried to compile the program:

catkin_make --source ~/Desktop/MSF_PACKAGE/glog_catkin-master/
source devel/setup.bash
rospack profile

and repeated this for all the other packages.

Any help would be appreciated. Thanks!

EDIT: was able to compile the project by moving all the packages into the src folder of my catkin workspace and compiling them together. And I was also able to launch partially by adding the sensor package name. However, I get a new error while working:

auto-starting new master
process[master]: started with pid [16492]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 0796c054-ff31-11e8-8252-b8ac6f4a40fe
process[rosout-1]: started with pid [16505]
started core service [/rosout]
ERROR: cannot launch node of type [msf_updates/pose_sensor]: can't locate node [pose_sensor] in package [msf_updates]
process[initialize-3]: started with pid [16523]

From the reading that I have been doing, it seems like a CMakeLists issue. But I tried changing the list by adding the executables before find_package() and it did not work. Any help would be appreciated. Thanks!

edit retag flag offensive close merge delete