API version mismatch:librealsense

asked 2018-12-09 07:43:11 -0600

ryota_m gravatar image

updated 2018-12-11 06:11:13 -0600

Hello. Last week, I tried to downgrade the version of librealsense2(2.16.4-0~realsense0.127) to librealsense2(2.8.1-0~realsense0.41) for using this face_detector library.(http://wiki.ros.org/face_detector) Like this...↓

$ dpkg -l | grep "realsense" | cut -d " " -f 3 | xargs sudo dpkg --purge //delete all of librealsense
$ sudo apt install librealsense2-udev-rules=2.8.1-0~realsense0.41
$ sudo apt install librealsense2-dkms=1.3.1-0ubuntu3
$ sudo apt install librealsense2=2.8.1-0~realsense0.41
$ sudo apt install librealsense2-utils=2.8.1-0~realsense0.41
$ sudo apt install librealsense2-dev=2.8.1-0~realsense0.41
$ sudo apt install librealsense2-dbg=2.8.1-0~realsense0.41

But it couldnt work,so I upgrade librealsense2(2.17.0-0~realsense0.256).

$ dpkg -l | grep "realsense" | cut -d " " -f 3 | xargs sudo dpkg --purge //delete all of librealsense
$ sudo apt install librealsense2-udev-rules=2.17.0-0~realsense0.256
$ sudo apt install librealsense2-dkms
$ sudo apt install librealsense2=2.17.0-0~realsense0.256
$ sudo apt install librealsense2-utils
$ sudo apt install librealsense2-dev
$ sudo apt install librealsense2-dbg

Then I tried realsense-viewer v2.17.0 ,I couldn't find realsense. And I often use ROS, so I tried

$ roslaunch realsense2_camera rs_rgbd.launch 
[ERROR] [1544361373.995566111]: Failed to load nodelet [/camera/realsense2_camera] of type [realsense2_camera/RealSenseNodeFactory] even after refreshing the cache: API version mismatch: librealsense.so was compiled with API version 2.17.0 but the application was compiled with 2.16.1! Make sure correct version of the library is installed (make install)

So, something version2.61.1 is left, but I couldnt find where it is... How can I use librealsense v2.17.0-0?

Add Information(2018/12/11) These are file's name which has the character "librealsense", what I have. I dont know, how can I compile the application with 2.17.0. If someone knows, it will be helpful if you tell me, please.

$ apt search librealsense
librealsense2/xenial 2.17.0-0~realsense0.256 amd64
Intel(R) RealSense(tm) Cross Platform API - runtime

librealsense2-dbg/xenial 2.17.0-0~realsense0.256 amd64
Intel(R) RealSense(tm) Camera Capture API - debug symbols

librealsense2-dev/xenial 2.17.0-0~realsense0.256 amd64
Intel(R) RealSense(tm) Camera Capture API - development files

librealsense2-dkms/xenial 1.3.4-0ubuntu1 all
Modified kernel modules for librealsense2

librealsense2-udev-rules/xenial 2.17.0-0~realsense0.256 amd64
Intel(R) RealSense(tm) Camera Capture API - udev rules

librealsense2-utils/xenial 2.17.0-0~realsense0.256 amd64
Intel(R) RealSense(tm) Camera Capture API - utils and demos

realsense-sdk-dev/xenial 2.7.7-0~realsense0.29 amd64
Intel(R) RealSense(tm) Camera Capture API - development files

realsense-sdk-utils/xenial 2.7.7-0~realsense0.29 amd64
Intel(R) RealSense(tm) Camera Capture API - utils and demos

ros-kinetic-librealsense/xenial 1.12.1-0xenial-20180809-140204-0800 amd64
Library for capturing data from the Intel(R) RealSense(TM) F200, SR300, R200, LR200 and ZR300 cameras.

Please excuse me if you may not understand or you feel bad with my poor English.

edit retag flag offensive close merge delete

Comments

Can you please stop bumping your question? If there are no responses (yet), that means either no one knows, or they haven't seen the question yet. It's rather unfair to keep pushing your question to the top of the list with empty edits.

Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2018-12-10 00:39:25 -0600 )edit

I'm sorry. I didnt understand, the system of editting. It won't happen again.

ryota_m gravatar imageryota_m ( 2018-12-10 20:56:13 -0600 )edit
1

You might want to post this issue over at the librealsense issue tracker, seeing as it's potentially an issue with either their recent release or their way of building / releasing their packages.

gvdhoorn gravatar imagegvdhoorn ( 2018-12-11 06:14:27 -0600 )edit

I read the GitHub about librealsense SDK, and tried to adapt 2.17.0version, but I couldnt find the answer. So I deleted all , and start to install version 2.16.1 again. This is not a fundamental solution, but this problem has ended. Thnak you for your kindness.

ryota_m gravatar imageryota_m ( 2018-12-14 11:14:45 -0600 )edit