Ask Your Question
0

I am workin with Ubuntu 16.04 - ROS Kinetic

asked 2018-10-02 15:05:49 -0500

marcusvini178 gravatar image

updated 2018-10-02 19:44:00 -0500

jayess gravatar image

I am having not success in launch a file: I am training the book "Mastering ROS for Robotics programming", In page 69, I am having a problem to visualize the pan and tilt mechanism in RViz....I have already checked the file urdf called view_demo that I made, the check was well succed but when I give Ros launch view_demo in mastering_ros_robot_descritpion. The terminal gives me the following message error:

[view_demo.launch] is neither a launch file in package [mastering_ros_robot_descritption_pkg] nor is [mastering_ros_robot_descritption_pkg] a launch file name The traceback for the exception was written to the log file

What does this mean? How Can I solve this problem? Can someone help me please?

edit retag flag offensive close merge delete

Comments

Hi, can you copy & paste the command and error exactly? That will help in debugging.

clyde gravatar image clyde  ( 2018-10-02 19:33:02 -0500 )edit
1
mastering_ros_robot_descritption_pkg

this seems like a typo. Notice the "descritption" instead of "description".

gvdhoorn gravatar image gvdhoorn  ( 2018-10-03 02:51:05 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-10-03 07:26:33 -0500

marcusvini178 gravatar image

Thanks guys I solved the problem! The Launch command was not working because I did not give the command to read the current directory, where the launch file were located. So I typed $ roscd mastering_ros_robot_description..." and later "cd urdf", then as an input I typed check pan_tilt_urdf....finally the check step was a succes! Later I entered with the command roslaunch in the directory launch...so the robot I have described in gedit.urdf appeared finally in RViz.... I am very happy, because I am new in using ROS. But now I have a doubt, several of you have suggested to me using the command "deverl/setup.bash", for what reasons are these commands used? Now I am facing a new problem, if you could help me, so I will be grateful! The problem is the following. I have constructed the robot not in URFD but in XACRO....so the tutorial says me to convert the Xacro in Urdf extension....well I tried but so the following error message appears to me on the terminal: xacro:

"Traditional processing is deprecated. Switch to --inorder processing! To check for compatibility of your document, use option --check-order. For more infos, see http://wiki.ros.org/xacro#Processing_...

So, I have clicked in the link, I have read the topics and later I tried the command "rosrun xacro xacro.py --inorder pan_tilt.xacro > pan_tilt_generated.urdf" instead the original command suggested by the book "rosrun xacro xacro.py pan_tilt.xacro > pan_tilt_generated.urdf" This last command was the command that generated the error depicted above, and the first command also didn't give me a correct feedback, in other words, the xacro was not converted again in urdf.

Could someone explain me what is happening? I am not understanding...

Thanks!

edit flag offensive delete link more

Comments

1

I'm glad your original problem was solved! This is a new problem, so you should start a new question. Please remember to cut & paste commands and errors directly into your correspondence. Resist the urge to re-type them: that introduces typos, and the answers you get will be: "that's a typo."

clyde gravatar image clyde  ( 2018-10-03 12:24:07 -0500 )edit
0

answered 2018-10-02 16:24:55 -0500

chloe gravatar image

Sometimes I get this error when I forget to source the terminal first. Did you type

source ~/catkin_ws/devel/setup.bash

? (or whatever your ros workspace is called in lieu of "catkin_ws")

Sorry if unhelpful, I am new to ROS

edit flag offensive delete link more
0

answered 2018-10-02 23:27:54 -0500

kk2105 gravatar image

updated 2018-10-02 23:28:17 -0500

  1. Please check if you have added ROS in bashrc file.
  2. If it is not added, then try sourcing source /opt/ros/lunar/setup.bash
  3. Try running the launch file.
  4. If above 3 steps did not fix the issue, try sourcing source ~/catkin_ws/devel/setup.bash

I hope this helpful.

Thank you, KK

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-10-02 15:05:49 -0500

Seen: 158 times

Last updated: Oct 03 '18