Ask Your Question
0

Running tf2_web_republisher leads to segmentation fault

asked 2018-09-26 04:12:53 -0500

aks gravatar image

I am trying to use the roslibpy for ROSbridge. For that I first needed to install ROS bridge. After installing ROS, i followed the instructions here I could install the rosbridge_server as well as web_republisher. But as soon as I try to run the republisher by using rosrun tf2_web_republisher tf2_web_republisher, it gives me an error Segmentation fault (core dumped). I have tried this on multiple PC's now and it gives me the same error always at this point.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-10-11 07:14:10 -0500

sharath gravatar image

Re-install ros-kinetic and then install tf2_web_republisher. Its weird but the segmentation fault stops occurring

edit flag offensive delete link more

Comments

You probably don't need to reinstall everything, but you will need to upgrade all ROS packages.

An ABI breakage was introduced a few weeks ago and we're still experiencing the fall-out of that.

gvdhoorn gravatar imagegvdhoorn ( 2018-10-11 07:36:08 -0500 )edit

I agree that's a better way to do it. I was not able to find command of how to upgrade only the ROS packages. Do you think the following commands might be able to do it? $ sudo apt-get update $ sudo apt-get --only-upgrade ros-kinetic-*

sharath gravatar imagesharath ( 2018-10-11 21:27:28 -0500 )edit

@gvdhoorn : do you know a command to upgrade the ROS packages ?

aks gravatar imageaks ( 2018-10-23 09:55:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-09-26 04:12:53 -0500

Seen: 78 times

Last updated: Oct 11 '18