Ask Your Question
0

[Kinetic] mapping is inaccurate

asked 2018-08-27 09:30:52 -0600

gavindvs gravatar image

updated 2018-08-28 05:13:15 -0600

Hi all I created my own launch file for gmapping however the map generated in RVIZ is really inaccurate compared to the Gazebo world. Is there any solution to this? My robot's speed was at 10 on the keyboard teleop and rotation was done in slow movements. My launch file codes are as follows:

File: my_gmapping_launch.launch

<launch>
  <arg name="scan_topic"  default="scan" />

  <node pkg="gmapping" type="slam_gmapping" name="slam_gmapping" output="screen">

    <rosparam file="$(find my_mapping_launcher)/params/gmapping_params.yaml" command="load" />

    <remap from="scan" to="$(arg scan_topic)"/>
  </node>
</launch>

File: gmapping_params.yaml

base_frame: base_footprint
odom_frame: odom
map_update_interval: 5.0
maxUrange: 6.0
maxRange: 8.0

minimumScore: 200

linearUpdate: 0.1
angularUpdate: 0.1
temporalUpdate: -1.0
resampleThreshold: 0.5
particles: 80
lskip: 10
xmin: -10
ymin: -10
xmax: 10
ymax: 10

delta: 0.05
llsamplerange: 0.01
llsamplestep: 0.01
lasamplerange: 0.005
lasamplestep: 0.005

RVIZ mapping result and RVIZ settings -

image description image description image description

Gazebo world -

image description

After creating my map I'll be running my amcl launch file to localize my robot in the map.


Edit: My map result after changing to a more defined world for my turtlebot.

image description image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-27 12:15:47 -0600

If there aren't a great deal of unique features to match against and track, most SLAM systems will have problems producing quality maps. For the map you show, this isn't unexpected (though I'm a little surprised) given that I believe default settings on the turtlebot give you zero-noise pose estimates.

Try adding some unique things (or more of them) from the laser scanners perspective.

edit flag offensive delete link more

Comments

Tried changing to a more defined environment tho still getting poor mapping results :( also my robot keeps jumping from point to point during the mapping process which messes up the map. Changing the fixed frame to odom helps but then I'm affected by the odom's drift / inaccuracy over time.

gavindvs gravatar image gavindvs  ( 2018-08-28 05:07:53 -0600 )edit

My latest edit contains my latest map. When I had used /map as the fixed frame under RViz, to lower the amount of jumping of my robot I changed the minimumScore from my parameter file to 100000, previously minimumScore: 200.

gavindvs gravatar image gavindvs  ( 2018-08-28 05:10:39 -0600 )edit

Tho the jumping still remained, it was just reduced :(

gavindvs gravatar image gavindvs  ( 2018-08-28 05:11:29 -0600 )edit

Again, these environments are not feature rich. You have environments that have all just straight lines or exact shaped objects with no texture, its hard to find a solution when things are so idealistically perfect. Try using the construction cone default scene

stevemacenski gravatar image stevemacenski  ( 2018-08-28 11:10:29 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-08-27 09:30:52 -0600

Seen: 269 times

Last updated: Aug 28 '18