Ask Your Question
0

velodyne HDL -64E S2 launch file configuration

asked 2018-08-10 02:07:50 -0600

Ajay gravatar image

updated 2018-08-10 02:13:27 -0600

Hello All,

I am currently working with velodyne HDL -64E S2 model of LiDAR and am trying to get data using ROS package with modifying to the launch file configuration.

 <launch>
    <!-- pointcloud cloud_nodelet -->
      <arg name="velodyne_calibration" default="$(find velodyne_pointcloud)/params/hdl64e_s2_calib.yaml" />
      <!-- <arg name="velodyne_calibration" default="" /> -->
      <arg name="min_range" default="2.0" />
      <arg name="max_range" default="65.0" />
      <node pkg="nodelet" type="nodelet" name="cloud_nodelet"
            args="load velodyne_pointcloud/CloudNodelet velodyne_nodelet_manager">
        <param name="calibration" value="$(arg velodyne_calibration)"/>
        <param name="min_range" value="$(arg min_range)"/>
    <param name="max_range" value="$(arg max_range)"/>
  </node>

  <!-- start nodelet manager and load driver nodelet -->
  <node pkg="nodelet" type="nodelet" name="velodyne_nodelet_manager"
        args="manager" />
  <arg name="model" default="64E_S2" />
  <arg name="pcap" default="" />
  <arg name="read_once" default="true" />
  <arg name="read_fast" default="true" />
  <arg name="repeat_delay" default="0.0" />
      <!-- rotating parameter -->
      <!-- 1) if your setting rpm is 1200(20Hz) -->
      <!-- <arg name="rpm" default="850.0" /> -->
      <!-- 2) if your setting rpm is 900(15Hz) -->
      <!-- <arg name="rpm" default="850.0" /> -->
  <!-- 3) if your setting rpm is 600(10Hz) -->

  <arg name="rpm" default="570.0" />

  <!-- 4) if your setting rpm is 300(5Hz) -->
  <!-- <arg name="rpm" default="290.0" /> -->

  <arg name="frame_id" default="velodyne" />

      <node pkg="nodelet" type="nodelet" name="driver_nodelet"
            args="load velodyne_driver/DriverNodelet velodyne_nodelet_manager" >
        <param name="model" value="$(arg model)"/>
        <param name="pcap" value="$(arg pcap)"/>
        <param name="read_once" value="$(arg read_once)"/>
        <param name="read_fast" value="$(arg read_fast)"/>
        <param name="repeat_delay" value="$(arg repeat_delay)"/>
        <param name="rpm" value="$(arg rpm)"/>
        <param name="frame_id" value="$(arg frame_id)"/>
      </node>
</launch>

//=========================================================================================== Calibration file : hdl64e_s2_calib.yaml

lasers:
- {dist_correction: 0.981637605, dist_correction_x: 0, dist_correction_y: 0, focal_distance: 0,
  focal_slope: 0, horiz_offset_correction: 0.025999999, laser_id: 0, max_intensity: 255,
  min_intensity: 0, rot_correction: -0.09709912400667693, vert_correction: -0.12678532453409336,
  vert_offset_correction: 0.19740748}
- {dist_correction: 1.2924338, dist_correction_x: 0, dist_correction_y: 0, focal_distance: 0,
  focal_slope: 0, horiz_offset_correction: -0.025999999, laser_id: 1, max_intensity: 255,
  min_intensity: 0, rot_correction: -0.06057167088908498, vert_correction: -0.12094779159811801,
  vert_offset_correction: 0.19783373}
- {dist_correction: 1.270309331, dist_correction_x: 0, dist_correction_y: 0, focal_distance: 0,
  focal_slope: 0, horiz_offset_correction: 0.025999999, laser_id: 2, max_intensity: 255,
  min_intensity: 0, rot_correction: 0.0384232803656565, vert_correction: 0.003765600221055326,
  vert_offset_correction: 0.20684389}
- {dist_correction: 1.2513616650000001, dist_correction_x: 0, dist_correction_y: 0,
  focal_distance: 0, focal_slope: 0, horiz_offset_correction: -0.025999999, laser_id: 3,
  max_intensity: 255, min_intensity: 0, rot_correction: 0.07774204553728, vert_correction: 0.008671371682560988,
  vert_offset_correction: 0.20719664999999998}
- {dist_correction: 1.0604789110000001, dist_correction_x: 0, dist_correction_y: 0,
  focal_distance: 0, focal_slope: 0, horiz_offset_correction: 0.025999999, laser_id: 4,
  max_intensity: 255, min_intensity: 0, rot_correction: -0.02274002397859877, vert_correction: -0.11631209238506594,
  vert_offset_correction: 0.1981718}
- {dist_correction: 1.3109244240000002, dist_correction_x: 0, dist_correction_y: 0,
  focal_distance: 0, focal_slope: 0, horiz_offset_correction: -0.025999999, laser_id: 5,
  max_intensity: 255, min_intensity: 0, rot_correction: 0.01614102308860006, vert_correction: -0.10965216030555087,
  vert_offset_correction: 0.19865684000000003}
- {dist_correction: 1.084458345, dist_correction_x: 0, dist_correction_y: 0, focal_distance: 0,
  focal_slope: 0, horiz_offset_correction: 0.025999999, laser_id: 6, max_intensity: 255,
  min_intensity: 0, rot_correction: -0.03625398445841397, vert_correction: -0.1508442868471072,
  vert_offset_correction: 0.19564366}
- {dist_correction: 1.3612504920000001, dist_correction_x: 0, dist_correction_y: 0,
  focal_distance: 0, focal_slope: 0, horiz_offset_correction: -0.025999999, laser_id: 7,
  max_intensity: 255, min_intensity: 0, rot_correction: 0.003226443580504749, vert_correction: -0.14504506388821317,
  vert_offset_correction: 0.19606992}
- {dist_correction: 0.9976554000000001, dist_correction_x: 0, dist_correction_y: 0,
  focal_distance: 0, focal_slope: 0, horiz_offset_correction: 0.025999999 ...
(more)
edit retag flag offensive close merge delete

Comments

1

I dont think that the calibration file will give us much info in this case. What is the problem with the projection? As far as I can see it looks pretty good. Is it a scaling problem?

pavel92 gravatar imagepavel92 ( 2018-08-10 02:35:44 -0600 )edit

Hello Pavel, Again Thanks for your quick response. The problem with current projection is that, planar surface points also mapped in different depth values. Each channel data has varied depth values. PLease observe the wall points its not clear.

Ajay gravatar imageAjay ( 2018-08-10 02:55:59 -0600 )edit
1

aha I see. Little variance in the channels is expected, but if it is greater than you are right to suspect the calibration

pavel92 gravatar imagepavel92 ( 2018-08-10 03:22:08 -0600 )edit

Even I have tried with different calibration file, which is I found online. But each calibration files has a different projection result. Few are very very bad, few are good. One that I posted is good one I found so far. So it made me clear that the issue is related to the calibration file.

Ajay gravatar imageAjay ( 2018-08-10 03:34:07 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-10 04:01:21 -0600

pavel92 gravatar image

There is a separate branch in the velodyne repo. It is supposed to contain fixes for the 32 LiDAR so you can give it a try.
Take a look at maint/vlp_32c_support branch.

edit flag offensive delete link more

Comments

1

Thank you Pavel, Finally, the problem got solved. I received a calibration file from the Velodyne technical support. Also, they mentioned that each unit of the Velodyne sensor comes with the separate calibration file. Thanks a lot for Velodyne Technical Support, for their quick and perfect response.

Ajay gravatar imageAjay ( 2018-08-10 18:50:14 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-08-10 02:07:50 -0600

Seen: 177 times

Last updated: Aug 10 '18