load yaml into rviz

asked 2018-07-20 14:50:41 -0500

Samily gravatar image

updated 2018-07-20 17:53:46 -0500

jayess gravatar image

Hi, I am trying to load the map into Rviz using a .png image drawn by Print in Windows through a .yaml file. However, it doesn't work. The Global Stutas is warning or error, and it shows

No tf data. Actual error: Fixed Frame [map] does not exist.

The content in the .yaml file as follow:

image: mymap.png
resolution: 0.050000
origin: [-100.000000, -100.000000, 0.000000]
negate: 0
occupied_thresh: 0.65
free_thresh: 0.196

I have been try to change the .png file into .pgm, but it also doesn;t work.

PS. I use Ubuntu 16.06 with ROS Kinetic.

edit retag flag offensive close merge delete

Comments

You say a couple of times

it doesn't work

but you don't say what you've tried exactly and what the results are (beyond not working). Can you please update your question with some explanation of what you've done and what the results are?

jayess gravatar imagejayess ( 2018-07-20 17:55:18 -0500 )edit

I'm not sure I understand how you're trying to do this. RVIZ doesn't load maps, it receives map messages from other nodes though. Are you using a separate node to load the image and publish a map?

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-07-21 02:31:16 -0500 )edit

I use map_server to publish map message which can be seen by using rostopic list. I first use mymap.yaml file with mymap.png. And then I try the .yaml file with mymap.pgm. Both are show the same result: No tf data. Fixed Fram [map] doesn’t exist. However, I can echo the data from /map topic.

Samily gravatar imageSamily ( 2018-07-21 03:28:00 -0500 )edit