ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

(RT_LIBRARY-NOTFOUND) unset. Message: RT Library

asked 2018-07-15 19:22:23 -0500

jitsunen gravatar image

updated 2018-07-17 06:00:43 -0500

Tom Moore gravatar image


I am trying to follow the ROS tutorial and create my own package. I see the following error when I try to invoke catkin_make:

Base path: /home/parth/dev/ros
Source space: /home/parth/dev/ros/src
Build space: /home/parth/dev/ros/build
Devel space: /home/parth/dev/ros/devel
Install space: /home/parth/dev/ros/install
#### Running command: "cmake /home/parth/dev/ros/src -DCATKIN_DEVEL_PREFIX=/home/parth/dev/ros/devel -DCMAKE_INSTALL_PREFIX=/home/parth/dev/ros/install -G Unix Makefiles" in "/home/parth/dev/ros/build"
-- Using CATKIN_DEVEL_PREFIX: /home/parth/dev/ros/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/lunar
-- This workspace overlays: /opt/ros/lunar
-- Using PYTHON_EXECUTABLE: /home/parth/anaconda3/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/parth/dev/ros/build/test_results
-- Found gmock sources under '/usr/src/gmock': gmock will be built
-- Found gtest sources under '/usr/src/gmock': gtests will be built
-- Using Python nosetests: /home/parth/anaconda3/bin/nosetests
CMake Error at /opt/ros/lunar/share/catkin/cmake/assert.cmake:17 (message):

  Assertion failed: check for file existence, but filename
  (RT_LIBRARY-NOTFOUND) unset.  Message: RT Library

Call Stack (most recent call first):
  /opt/ros/lunar/share/catkin/cmake/tools/rt.cmake:42 (assert_file_exists)
  /opt/ros/lunar/share/catkin/cmake/all.cmake:147 (include)
  /opt/ros/lunar/share/catkin/cmake/catkinConfig.cmake:20 (include)
  CMakeLists.txt:52 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/parth/dev/ros/build/CMakeFiles/CMakeOutput.log".
See also "/home/parth/dev/ros/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed
edit retag flag offensive close merge delete


When you're referring to a tutorial or some other source, please include a link to it

jayess gravatar image jayess  ( 2018-07-15 21:21:54 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted

answered 2018-07-17 06:02:24 -0500

Tom Moore gravatar image

The only time I've seen this error, cleaning my workspace fixed it. I'd also recommend using catkin tools (i.e., run catkin build instead of catkin_make).

edit flag offensive delete link more

answered 2019-01-31 19:42:27 -0500

harderthan gravatar image


Remove the CMakeLists.txt on your catkin workspace for catkin_make.

ex) $ rm -rf ${CATKIN_PATH}/src/CMakeList.txt

And, rebuild it.

$ catkin_make

edit flag offensive delete link more

answered 2018-07-17 21:30:00 -0500

jitsunen gravatar image

updated 2018-07-17 21:36:42 -0500

Tom Moore, thanks for the tip! In order to make catkin build work, I discovered that some of the python modules were missing. I had to install catkin_tools, trollius and catkin build worked. I also had to comment out the RT_LIBRARY check in /opt/ros/lunar/share/catkin/cmake/tools/rt.cmake. I read on some other post that this dependency was not required to build packages (not sure if that's true, but I decided to give it a try).

I also tried catkin_make after catkin build and that worked as well. So, I guess installing the missing python modules did the trick.

Thanks to everyone for their comments!. I appreciate the quick turn around time.

edit flag offensive delete link more



Glad that you got it working, although having to modify rt.cmake doesn't sounds a right, permanent solution.

130s gravatar image 130s  ( 2018-08-08 13:49:59 -0500 )edit

answered 2023-01-10 03:54:51 -0500

I keep stumbling into this then finding a solution and forgetting about it, so here it is: the problem is that CMAKE_LIBRARY_ARCHITECTURE is not set by cmake automatically in some cases when the project language is not specified explicitly, so make sure that CMakeLists.txt contains project(myproject CXX).

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-07-15 19:22:23 -0500

Seen: 7,431 times

Last updated: Jan 10