ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

camera_calibration for monocamera

asked 2018-07-03 05:25:30 -0500

Jiaxing gravatar image

updated 2019-05-23 00:00:44 -0500

jayess gravatar image

when I use this commend to calibrate my monocamera , i got the folling problem. Itried to find answer in the internet. but it seems like nobody had ever happend. so please..

 rosrun camera_calibration --size 8x6 --square 0.108 image:=/usb_cam_node/image_raw camera:=/usb_cam_node

Traceback (most recent call last):
  File "/home/jiaxing/catkin_ws/src/image_pipeline/camera_calibration/nodes/", line 40, in <module>
    from camera_calibration.camera_calibrator import OpenCVCalibrationNode
ImportError: No module named camera_calibration.camera_calibrator
edit retag flag offensive close merge delete


I have the same problem,could you tell me How did you solve it?

bob1729 gravatar image bob1729  ( 2020-09-01 04:31:10 -0500 )edit

@bob1729 I've reposted your answer as a question comment. This is a Q&A site, not a discussion forum. Please do not post answers that aren't actually answers. If you have follow-ups use comments or ask a new question. See more on the support page:

jarvisschultz gravatar image jarvisschultz  ( 2020-09-01 09:07:12 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-07-03 06:41:06 -0500

simbha gravatar image

You should check the topic before write command.

if you are using usb_cam package then it publishes the image on usb_cam/image_raw.

Change your command as given below.

rosrun camera_calibration --size 8x6 --square 0.108 image:=/usb_cam/image_raw camera:=/usb_cam
edit flag offensive delete link more


hi Thanks for your reply. the rostopic list is correct (i think):

jiaxing@jiaxing-HP-ENVY-15-Notebook-PC:~$ rostopic list

/rosout /rosout_agg /usb_cam_node/camera_info /usb_cam_node/image_raw

Jiaxing gravatar image Jiaxing  ( 2018-07-03 06:44:09 -0500 )edit

is there any warning/error after the command?

simbha gravatar image simbha  ( 2018-07-03 06:46:29 -0500 )edit

no warnung with this commend. after I run the following commend,

roslaunch usb_cam usb_cam-test.launch

Ican see the camera light is turned on. but tehre is no window open to see the image from the camera. IN the terminal shows the following respond

[swscaler@0x1cb9620] deprecated pixe...
Jiaxing gravatar image Jiaxing  ( 2018-07-03 09:14:37 -0500 )edit

Is the camera correctly turned on?

Jiaxing gravatar image Jiaxing  ( 2018-07-03 09:15:41 -0500 )edit

please check your camera using cheese

simbha gravatar image simbha  ( 2018-07-03 12:32:56 -0500 )edit

answered 2018-07-26 12:17:10 -0500

fayyaz gravatar image

It is showing deprecated may be because you have set the pixel format as mjepg

edit flag offensive delete link more


thank you for your replay. I have solved this problem.

Jiaxing gravatar image Jiaxing  ( 2018-08-07 03:46:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2018-07-03 05:25:30 -0500

Seen: 382 times

Last updated: May 23 '19