How to improve amcl performance?

asked 2018-06-22 09:20:07 -0500

schizzz8 gravatar image

Hi all,

I made a simulated environment and a robot in Gazebo and I'm trying to localize the robot on a map with amcl.

So, what I did so far was to:

  • launch the simulation environment

  • run the map_server with the available map

  • run amcl

  • open rviz to see the result

and this is what happens:

https://youtu.be/8glw9rP98LI

As soon as the robot turns the pose estimate is very bad. Can please someone give me some hint on how to get this working?

Thanks.

edit retag flag offensive close merge delete

Comments

This looks to me like potentially 2 things: 1, that your URDF with your laser might not be correctly configured, so that when you turn, it offset by a bad amount. 2, simulation environments have issues with AMCL due to lack of unique features from its "perfectness" if you give us your urdf/configs..

stevemacenski gravatar imagestevemacenski ( 2018-06-23 00:40:21 -0500 )edit

... we might be able to help narrow down more

stevemacenski gravatar imagestevemacenski ( 2018-06-23 00:40:28 -0500 )edit

sure! all the config files are in this package ( https://github.com/schizzz8/lucrezio_... ) to test it run: roslaunch lucrezio_simulation_environments empty_world_with_apartment_and_robot.launch

schizzz8 gravatar imageschizzz8 ( 2018-06-23 03:37:31 -0500 )edit