Ask Your Question
1

ur5 - real hardware communication

asked 2018-06-18 10:04:24 -0500

enrico gravatar image

updated 2018-06-20 08:36:18 -0500

Hi all! I tried to communicate with the real UR5 hardware and I was able to move the robot running "test_move.py" from the "ur_modern_driver package". After that I tried to move the robot with MoveIt! following this tutorial: Getting Started with a Universal Robot and ROS-Industrial.

Problems arise when launching this command:

roslaunch ur5_moveit_config ur5_moveit_planning_execution.launch limited:=true

In the terminal the following lines appear:

[ WARN] [1529329845.474785699]: Waiting for /joint_trajectory_action to come up
[ WARN] [1529329851.474995251]: Waiting for /joint_trajectory_action to come up
[ERROR] [1529329857.475168563]: Action client not connected: /joint_trajectory_action

So that when i launch MoveIt (by typing roslaunch ur5_moveit_config moveit_rviz.launch config:=true) to try planning and execution, the planning is ok but the execution never works. And the same is with using the limited version (limited:=true).

If I go into the controllers.yaml file and I change action_ns from joint_trajectory_action to follow_joint_trajectory the execution still doesn't work, but the WARNS and the ERROR above does not appear anymore.

Thanks in advance to anyone who will help solving this.

My Ubuntu version: 16.04 ROS Kinetic

edit: here is the output I get when i "roslaunch" the driver

roslaunch ur_modern_driver ur5_bringup.launch limited:=true robot_ip:=192.168.0.9

started roslaunch server http://Kazar:40451/

SUMMARY
========

PARAMETERS
 * /robot_description: <?xml version="1....
 * /rosdistro: kinetic
 * /rosversion: 1.12.13
 * /ur_driver/base_frame: base
 * /ur_driver/max_payload: 5.0
 * /ur_driver/max_velocity: 10.0
 * /ur_driver/min_payload: 0.0
 * /ur_driver/prefix: 
 * /ur_driver/require_activation: Never
 * /ur_driver/robot_ip_address: 192.168.0.9
 * /ur_driver/servoj_time: 0.008
 * /ur_driver/shutdown_on_disconnect: True
 * /ur_driver/tool_frame: tool0_controller

NODES
  /
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    ur_driver (ur_modern_driver/ur_driver)

auto-starting new master
process[master]: started with pid [12815]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 25cfb476-7486-11e8-a63f-2c600c364ff4
process[rosout-1]: started with pid [12828]
started core service [/rosout]
process[robot_state_publisher-2]: started with pid [12839]
process[ur_driver-3]: started with pid [12846]
[ INFO] [1529498015.883288664]: Setting up connection: 192.168.0.9:30003
[ INFO] [1529498015.883464161]: Connection established for 192.168.0.9:30003
[ INFO] [1529498015.883497685]: Setting up connection: 192.168.0.9:30001
[ INFO] [1529498015.883597424]: Connection established for 192.168.0.9:30001
[ INFO] [1529498015.985030774]: Got VersionMessage:
[ INFO] [1529498015.985066182]: project name: URControl
[ INFO] [1529498015.985080850]: version: 3.4.1
[ INFO] [1529498015.985093590]: build date: Apr 03 2017, 13:36:51
[ INFO] [1529498015.985105979]: Disconnecting from 192.168.0.9:30001
[ INFO] [1529498015.993302131]: Setting up connection: :50001
[ INFO] [1529498015.993434163]: Connection established for :50001
[ INFO] [1529498015.993464770]: ActionServer enabled
[ INFO] [1529498015.993524619]: Initializing ur_driver/URScript subscriber
[ INFO] [1529498015.996961509]: The ur_driver/URScript initialized
[ INFO] [1529498015.997002449]: Notifier: Pipeline disconnect will shutdown the node
[ INFO] [1529498016.001166449]: Service 'ur_driver/robot_enable' activation mode: Never
[ INFO] [1529498016.001225580]: Starting main loop
[ INFO] [1529498016.001343519]: Setting up connection: 192.168.0.9:30003
[ INFO] [1529498016.001399087]: Starting pipeline RTPacket
[ INFO] [1529498016.001462871]: Setting up connection: 192.168.0.9:30002
[ INFO] [1529498016.001498371]: Connection established for 192.168.0.9:30003
[ INFO] [1529498016.001525872]: Starting pipeline StatePacket
[ INFO] [1529498016.001595757]: Connection established for 192.168.0.9 ...
(more)
edit retag flag offensive close merge delete

Comments

Which driver are you starting before you launch ur5_moveit_planning_execution.launch?

gvdhoorn gravatar imagegvdhoorn ( 2018-06-18 10:20:41 -0500 )edit

ur modern driver. I type this:

roslaunch ur_modern_driver ur5_bringup.launch robot_ip:=IP_OF_THE_ROBOT [reverse_port:=REVERSE_PORT]

enrico gravatar imageenrico ( 2018-06-18 10:38:50 -0500 )edit

You use that exact command? You do replace IP_OF_THE_ROBOT with an actual IP, correct? And the [reverse_port:=REVERSE_PORT] part, do you include that as well?

gvdhoorn gravatar imagegvdhoorn ( 2018-06-18 10:45:12 -0500 )edit

yes i replaced it with the actual IP of the robot. I forgot an important thing: the initial position visualized in Rviz is different from the one of the real robot. Then I change it using the marker, but maybe this doesn't solve the problem (in a terminal i noticed an error referring to this)

enrico gravatar imageenrico ( 2018-06-18 11:49:16 -0500 )edit

Everything you write points to the driver not actually having been successfully started. Can you please respond to this:

And the [reverse_port:=REVERSE_PORT] part, do you include that as well?

Please edit your question and show all console output you get when you roslaunch the driver.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-18 11:50:20 -0500 )edit

Yes I included also the [reverse_port:=REVERSE_PORT] part, without modifying it.

As soon as I will be able to interact with the robot again, I will edit my question showing the console output. I think it will require 1 or 2 days.Thanks for the support

enrico gravatar imageenrico ( 2018-06-18 13:36:02 -0500 )edit

Yes I included also the [reverse_port:=REVERSE_PORT] part, without modifying it.

then that is probably your problem. That part is optional, and should only be added if you need it. You probably don't, so don't use it.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-18 13:56:43 -0500 )edit

Thanks for the update, but please include the full roslaunch command you used to start it as well.

Also: I have the impression you are running the Zagitta fork or ur_modern_driver. It would have been good to mention that in your question text.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-20 08:25:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-10-11 16:01:51 -0500

enrico gravatar image

I bypassed the problem using ros_control instead of ur5_bringup.launch. So on the terminal, in order to connect to UR5, I type:

roslaunch ur_modern_driver ur5_ros_control.launch robot_ip:=["your IP"]
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-18 10:04:24 -0500

Seen: 368 times

Last updated: Oct 11 '18